1

I've been playing around with this to vary degrees of success and I'm getting slightly confused by what I'm seeing (or rather hearing in this case). Just playing the clips in a player like QT or VLC doesn't have any issues, so I know the source files are fine.

I started using Shadowplay recording video at the native resolution of my monitor which is 2560x1600. It offers limited resolution and FPS options like 1080p, 1440p 4K at 30 or 60fps.

All dandy, I started by just using native resolution and 60 fps. But when I imported this into iMovie I was getting audio issues.

In order to get over these issues I just transcoded these files in Handbrake, imported and edited those and exported just fine. I also at this point thought that it was the source resolution that was the issue so I setup shadowplay to use 1080p 60fps thinking that I could then skip the transcoding step, preserve a bit more quality and go straight into the editing.

Nope.

Seems even these 1080p 60fps source files when imported into iMovie have clicks and pops.

When I check the source files it seems that the FPS isn't 60 but is 59.9729 and the preset I created in Handbrake is a constant 60fps. Could this framerate difference be the source of the audio issue in iMovie?

The source file is 4.6GB but the transcoded file is only 366mb which is obviously a huge difference so I need to check the settings again. But I'm just curious if this framerate difference is the problem.

1

After some more digging around and reading on various forums it seems that this is actually a very common problem (along with other effects, not just audio artifacts) with recordings produced by Shadowplay and subsequently imported to many editors.

It seems the source of the problem is that all files produced with Shadowplay record using variable frame rates.

There is a discussion here and here that might be useful.

There is a Handbrake preset here to convert your Shadowplay files to CFR files with no compression.

Or alternatively you can stop using shadowplay completely, skip and transcoding steps and instead use OBS Studio (free) to record your footage.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.