1

I have a Magewell capture device that I'm trying to preview with ffplay. It works great, except over time the video will become choppy and lag behind the actual live feed. Right clicking on the ffplay window will sync it back up, however continuously right clicking it is obviously not a good solution.

I am using a command similar to the following to display my capture:

ffplay -f avfoundation -pix_fmt 0rgb -framerate 60 -i "1:none"

How do I get it to remain synced the entire time? Viewing ffplay stats shows that there is a buffer that gets filled over time and right clicking clears it. You can also force this by pausing the stream and unpausing. I need it to display without filling the buffer at all.

I've tried using this and it helps to some extent, but doesn't completely disable the buffer:

-probesize 32 -sync ext

With that it takes longer to fill as most frames are dropped if it can't read them fast enough, however it does still fill up over time.

2

So I solved this by simply adding an audio stream instead of having "none" selected. Doing this makes -framedrop (default) work properly. I left the master clock as default as well (audio) instead of changing it to ext.

  • Did you try "-an" instead of "1:none"? – junkyardsparkle Aug 14 '18 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.