2

Im trying to record Windows Desktop, a game (Worms Armageddon) which has about 50 frames per second. If I check it closely, I can see some frames are missed. The command:

ffmpeg -probesize 10M -rtbufsize 1500M -f dshow -i audio="virtual-audio-capturer" -acodec pcm_s16le -f gdigrab -framerate 60 -i desktop -vcodec libx264 -qp 0 -threads 0 -crf 0 -preset ultrafast -tune zerolatency output.mkv

what else can I do?

1 Answer 1

1

This might be an issue with the hardware unable to keep up with the required process of recording (compression) and writing to disk, which will result in dropped frames. That being said, your flag for crf should increase by a ton, and remove the qp flag. Set the crf to 17-25 to ease off the required processing power.

1
  • I would put all the blame on -crf 0. I'd bet -crf 18 will work just fine and look great.
    – user3643
    Dec 25, 2018 at 3:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.