1

I built a Facebook canvas advertisementwith a mixture of image, video, and carousel elements. When you first load the canvas element, the video elements match the other imagery used in the ad well. Here are some photos of what the video elements look like upon the first load of the canvas advertisement:

video element when ad is first loaded

However, once you click on the video element to play it, it becomes discolored with a blue hue. I have tried saving out the video in several different color ways and none worked. Currently, I am using no color management and it seems to be the closest match to the imagery.

Here are screen grabs of what the video elements look like after playing:

video element after pressing play

In the above images you can see the color difference and blue hue that appears after pressing play. Has anyone else experienced issues with Facebook advertisements or canvas elements that have become discolored after uploading through Facebook? I tried to ask on their forums but got no replies. Any insight on why this might be happening would be very much appreciated. Thank you!

  • Possible duplicate of Possible to use sRGB as mp4 colorspace? – Michael Liebman Mar 27 '17 at 22:17
  • Sorry, its not a duplicate of that question at all. I've already tried all color spaces my video editor could think of and it didn't work to solve my issue. This is not a color space issue. This is specifically a color issue within the Facebook canvas medium. – Liz Mar 28 '17 at 22:54
  • Hi Liz, have you tried Facebook Canvas forums? They may have more experience with problems specific to their software. – Dr Mayhem Apr 1 '17 at 15:17
  • Right, thank you - I tried that but it seems that those forums aren't that useful unfortunately. I posted a question a few weeks ago and haven't gotten a reply so I tried here. – Liz Apr 3 '17 at 23:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.