1

I'm using ffmpeg to capture a portion of my screen, save it as a movie file, and stream it to a Youtube live event. The result is a jerky movement. The log has some issues I'm not able to understand and solve. I did a lot of different try, but with no result.

This is the actual Command line I use:

"C:\\mbiWebTV\\programs\\ffmpeg\\bin_x86\\ffmpeg.exe" 
-thread_queue_size 512 -report -re -rtbufsize 2000M -f dshow 
-i "audio=Missaggio stereo (Realtek High Definition Audio)" 
-f dshow 
-i "video=screen-capture-recorder" -filter:v "crop=713:379:018:043" 
-s 848x480 -video_size 848x480 -vcodec libx264 -preset ultrafast 
-maxrate 6000 -bufsize 2000M -pix_fmt yuv420p -g 60 -acodec libmp3lame 
-b:a 128k -ac 2 -ar 44100 
-f flv rtmp://a.rtmp.youtube.com/live2/xxxx-xyyv-0rrm-f9g2 
-filter:v "crop=713:379:018:043" 
"c:\\mbiWebTV\\Capture\\Capture_20170225_165829.mkv"

I could send the complete log file. This is the error messages that frequently occurs:

[dshow @ 049a4240] real-time buffer [screen-capture-recorder] [video input] too full or near too full (545% of size: 3041280 [rtbufsize parameter])! frame dropped!


2

The rtbufsize is only affecting the audio.

Try

ffmpeg.exe
-thread_queue_size 512 -report -rtbufsize 100M -f dshow -i "audio=Missaggio stereo (Realtek High Definition Audio)"
-rtbufsize 1000M -thread_queue_size 512 -video_size 848x480 -f dshow -i "video=screen-capture-recorder"
-vf "crop=713:379:18:43,scale=848:480,setsar=1"
-vcodec libx264 -preset ultrafast -maxrate 6M -bufsize 12M -pix_fmt yuv420p -g 60
-acodec libmp3lame -b:a 128k -ac 2 -ar 44100
-f flv rtmp://a.rtmp.youtube.com/live2/xxxx-xyyv-0rrm-f9g2
-filter:v "crop=713:379:18:43" "c:\mbiWebTV\Capture\Capture_20170225_165829.mkv"
  • I changed only the position of -video_size 848x480 parameter and it worked very well. – bruno Feb 28 '17 at 9:08
  • The laptop I use is an Intel I7, now I made the same test on a different laptop (intel celeron) and after few second I get real-time buffer too full or near too full . – bruno Feb 28 '17 at 9:11
  • Output file #1 (c:\mbiWebTV\Capture\Capture_20170225_AAAAAA.mkv): Output stream #1:0 (video): 222 frames encoded; 222 packets muxed (366088 bytes); Output stream #1:1 (audio): 10680 frames encoded (683520 samples); 670 packets muxed (199011 bytes); Total: 892 packets (565099 bytes) muxed 253 frames successfully decoded, 0 decoding errors dshow passing through packet of type video size 8392758 timestamp – bruno Feb 28 '17 at 9:16
  • dshow passing through packet of type video size 8392758 timestamp 11976436850000 orig timestamp 11976436850000 graph timestamp 11976436850000 diff 0 screen-capture-recorder [dshow @ 04472460] real-time buffer [screen-capture-recorder] [video input] too full or near too full (86% of size: 1000000000 [rtbufsize parameter])! frame dropped! dshow passing through packet of type video size 8392758 timestamp 11976437520000 orig timestamp 11976437520000 graph timestamp 11976437520000 diff 0 screen-capture-recorder – bruno Feb 28 '17 at 9:18
  • You'll have to increase the rtbufsize.just before the video (provided you have enough ram). – Gyan Feb 28 '17 at 9:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.