0

I tried create a video file from the AviSynth script using this command (in Windows 7):

ffmpeg  -i  file.avs  file.mp4

and I got this message:

[avisynth @ 05000e60] AviSynth version is too old. Please upgrade to either
                      AviSynth 2.6 >= RC1 or AviSynth+ >= r1718.
                      file.avs: Unknown error occurred

Very clear recommendation (as I use AviSynth+ 0.1 (r1576, x86)) but I'm not able to find an newer version, neither for AviSynth, nor for AviSynth+.

Nevertheless, it was probably only an recommendation. The most important part is indeed this:

                      file.avs: Unknown error occurred

So I changed the content of the file.avs - I put only one command into it, enough simple and stupid, so my file.avs now looks like:

version

No change. The same message. So I kindly ask for an advice what to do.

(I tried it with versions 3.2.2 and 2.8.4 of ffmpeg, both of them report --enable-libxavs in their configuration and D avisynth AviSynth script in their file formats obtained by ffmpeg -formats.)

1 Answer 1

3

From FFmpeg source code:

On Windows, FFmpeg supports AviSynth interface version 6 or higher. This includes AviSynth 2.6 RC1 or higher, and AviSynth+ r1718 or higher, and excludes 2.5 and the 2.6 alphas.

From doom9:

The decision to drop support for anything below 2.6 RC1 was due to catastrophic header incompatibilities between 2.5 and 2.6 RC1* and the maintenance burden (and potential licensing minefield that could mean any additional 2.5 support would violate GPL) that would be incurred by trying to continue to support 2.5 while using properly updated 2.6 headers.


Get AviSynth+ r2420 from https://github.com/pinterf/AviSynthPlus/releases/tag/r2420-MT

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.