Using the command ffmpeg -formats, I can see that ffmpeg supports bink.

However when I use the following command:

ffmpeg -i F:\PathToFile\inputfile.bik F:\PathToFile\outputfile.mp4

I get the following error:

Invalid data found when processing input

Am I doing something wrong, do I need to supply other parameters in the command, or could it simply be that the input file is corrupt? How would I go about debugging the issue?

Note: I've tried this on the following two versions of FFMPEG: N-77782-g42c54d4 and N-82880-g02aa070. Both same result.

Edit: Full console output below. (Inserted line breaks between each configuration)

C:\FFMPEG\bin>ffmpeg -i F:\PathToFile\inputfile.bik F:\PathToFile\outputfile.mp4
ffmpeg version N-82880-g02aa070 Copyright (c) 2000-2016 the FFmpeg developers
built with gcc 5.4.0 (GCC)
configuration:
--enable-gpl
--enable-version3
--enable-dxva2 
--enable-libmfx 
--enable-nvenc 
--enable-avisynth 
--enable-bzlib 
--enable-fontconfig 
--enable-frei0r 
--enable-gnutls 
--enable-iconv 
--enable-libass 
--enable-libbluray 
--enable-libbs2b 
--enable-libcaca 
--enable-libfreetype 
--enable-libgme 
--enable-libgsm 
--enable-libilbc 
--enable-libmodplug 
--enable-libmp3lame 
--enable-libopencore-amrnb 
--enable-libopencore-amrwb 
--enable-libopenh264 
--enable-libopenjpeg 
--enable-libopus 
--enable-librtmp 
--enable-libsnappy 
--enable-libsoxr 
--enable-libspeex 
--enable-libtheora 
--enable-libtwolame 
--enable-libvidstab 
--enable-libvo-amrwbenc 
--enable-libvorbis 
--enable-libvpx 
--enable-libwavpack 
--enable-libwebp 
--enable-libx264 
--enable-libx265 
--enable-libxavs 
--enable-libxvid 
--enable-libzimg 
--enable-lzma 
--enable-decklink 
--enable-zlib
libavutil      55. 43.100 / 55. 43.100
libavcodec     57. 68.100 / 57. 68.100
libavformat    57. 61.100 / 57. 61.100
libavdevice    57.  2.100 / 57.  2.100
libavfilter     6. 68.100 /  6. 68.100
libswscale      4.  3.101 /  4.  3.101
libswresample   2.  4.100 /  2.  4.100
libpostproc    54.  2.100 / 54.  2.100
F:\PathToFile\inputfile.bik: Invalid data found when processing input
  • Show the full console output, with the newer version. – Gyan Dec 21 '16 at 3:47
  • @Mulvya See edited answer. – Mike Baxter Dec 21 '16 at 19:42
  • File may be corrupt. Try samples here. Also, Bink2 video is not supported. – Gyan Dec 21 '16 at 20:27
  • @Teifi A link to the input file may be helpful. – LordNeckbeard Dec 23 '16 at 0:18

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.