0

Im trying to set font and font size but i can use only one of the filters not both here is mine command

ffmpeg -i movie.avi -strict -2 -vf subtitles=subtile.srt:force_style='FontName=ubuntu, Fontsize=30' -qscale:v 3 out.avi

but I get

No such filter: 'Fontsize'

But if I set just Fontsize it works just fine, any help ? TNX in advance

2

I did solved this with " "

"subtitles=subtitle.srt:force_style='FontName=ubuntu,Fontsize=30'"
1

Remove the space.

ffmpeg -i movie.avi -strict -2 -vf subtitles=subtile.srt:force_style='FontName=ubuntu,Fontsize=30' -qscale:v 3 out.avi
9
  • Tnx for quick reply but Iv got same error [AVFilterGraph @ 0x1f56f20] No such filter: 'Fontsize' Dec 11 '16 at 18:06
  • This is a matter of which quote marks you're using. If I use double quotes, I get the same error. With single quotes, it works. Is your command run from inside a batch file?
    – Gyan
    Dec 11 '16 at 19:08
  • No its not its command line Im getting error and I using single quotes TNX Dec 11 '16 at 19:29
  • Show the full console output.
    – Gyan
    Dec 11 '16 at 19:34
  • Here you go pastebin.com/GWT0YMtW Dec 11 '16 at 19:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.