2

I recently faced a problem I never had before.

I made a video sequence using After Effects and 3D layers. Nothing has been filmed, it is completely virtual. It seems that some of my pans have a speed that makes them "stutter", or "judder", flick, jump, shake, or I don't know what is the exact term.

It does not shows up on a "regular" computer video output; but when conforming the project, it clearly shows up. I can also see it on a computer that has a BlackMagic video card output.

Here's a sample : https://vid.me/AavQ

I've read that a lot of people got this problem. English is not my mother tongue, so I'm not sure I understand everything, but there is even a post on Adobe.com about it : Avoiding Judder in Motion Graphics.

I'm looking for a technical solution to fix this. My movie is and should remains 25 fps, noninterlaced. The timing of my movement should basically remains the same because I can't afford retiming the whole movie (48 mins).

I already did try to play with the shutter angle, the motion blur (and number of samples); to force the blur with CC force motion blur, to slightly change the movement timing... But none works. Even if I set a very high level of blur, it keeps "blinking".

There is also an interesting topic about it here, where a guy eventually says:

Try panning the R, G and B channels at slightly different speeds. There is a correct order but DS guys have done this for years.

I still should try that but I wonder if this is not too much complicated and I'm not sure I know how to do that.

I would be very interested by your feedbacks and ideas about all that.

Thanks for your help !

1

I think the Adobe article you linked to spells it out pretty well, especially with respect to the "7 second rule". I think you're just panning too fast.

Fast pans don't like sharp lines that run counter to the pan's motion. If you absolutely must pan at that speed, you'll need to reduce detail (ie, contrasty edges) during the fast pans.

So for starters, I think you need a lot of motion blur. I wouldn't start by using an effect to create motion blur, though. Instead, try using AE's built-in motion blur. Assuming you're in the comp that has the motion keyframes, turn on the motion blur switch for your Painting layer (the little balls icon):

enter image description here

..and then enable motion blur globally using its global toggle button:

enter image description here

Now you can adjust the shutter angle, samples, etc by going to the Advanced tab of the Composition Settings. Set the shutter to the max value 720 just to see if it helps. Lower the value until the judder begins to return.

Adding some grain may help imperceptibly reduce some detail, too. (You can simply create a 50% gray solid, add the Add Grain effect, and set the transfer mode to Overlay.) Play with intensity and size, and monochromatic vs color grain, to see what feels best.

Lastly, I don't think CC Force Motion Blur is a good choice in this case. If the built-in motion blur described above still isn't 'smeary' enough to get rid of sharp edges during pans, try Pixel Motion Blur instead, and set the shutter to something high like 1000 (just to see if it fixes the problem) and then lower the value until the judder begins to return.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.