Using Nvidia's gpu accelerated codecs to encode videos is a massive time saver, it brings my encoding times down from 2 hours to 2 minutes with pascal GPU's however the problem with the codec that I am using (https://forums.adobe.com/thread/1243687) is that it outputs mkv or mk4 files which are all but useless as I can skip through the outputted video and youtube doesn't accept them at all.

I have tried running the NVenc through a filter/wrapper to package it up as an mp4 but either I was doing something wrong or it didn't work as the audio on the outputted file was always running at a different speed than the video itself, or the other way around.

Does anyone have any advice or instructions by chance? Would really appreciate it!

1 Answer 1


It's funny how you can try solutions for hours but the moment you post a question online or to IRC you find the answer yourself within minutes.. Anyways, digging around I found tat instead of using mp4box as my multiplexer I changed to TsMux as per the thread instructions and that still didnt' work however I noticed I had one more option, mkvmerge, so I tracked that down here: http://www.videohelp.com/software/MKVtoolnix , installed it and used that instead and viola, it did the trick. Was able to use the nvenc codec and get a video in the end that was accepted by youtube.

Now of course because I have solved this problem it would appear that the nvenc codec is no longer using my gpu at all after upgrading to the latest nvidia drivers so there's that issue to solve but at least I can use the codec and get useable vids. Hopefully this is useful to someone else experiencing the same issue down the road

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.