0

O.K. so i'll tell the full thing on whats happening! I have two compsitions; one is the spectrum layers composition (which contains some spectrum things) and the other is the music composition (which contains the music and key-frame assistant)! The problem is when i put the music composition into the spectrum layers composition, the music doesn't play in the background and the spectrums doesn't read anything. I go back to the original music/mp3 file and i works. I even go to the music composition, click on the mp3 file, double tap "l", and it shows the waveform but when i go to the spectrum layers composition, and i double tap "l", it shows no waveform. Is this a glitch or did i do something wrong because when i did this with other projects (and i accidentally delete them), it works but now i doesn't. I tried my method on most of my spectrum videos but just now it doesn't work! Can anyone help me? Thanks

P.S. Sometimes when i press the RAM Preview button in the music composition, it says "After Effects Warning: Unable to create drawing surface"! Maybe that has to do something with it?

1

Maybe a dumb question, but is the loudspeaker icon enabled next to the music composition layer, when you place it in your main comp?

Also, sometimes if I have weird things happening with mp3 files, I convert them to 44.1khz 16bit WAV files instead, just to rule out any mp3 oddness...

Have you definitely connected the Audio Spectrum effect to your audio layer, by choosing it in the Audio Spectrum's "Audio Layer" effect setting?

  • 1) Yes the speaker is on, i can hear it in the RAM Preview in the music composition but i cannot hear it in the other composition. – kevinbestkiller Jul 31 '16 at 17:43
  • What version of AE are you using? What platform? I did a quick test with an mp3 in CC 2015.3, nested in a comp, and it worked for me (realise this doesn't help much - sorry!) – tomh Jul 31 '16 at 17:45
  • 2)Yes i have the Audio Spectrum connected to the music composition which has music or the mp3 file in the composition (music) – kevinbestkiller Jul 31 '16 at 17:46
  • @tomp i have CS4 since i can't get CC cuz i have a 32 bit – kevinbestkiller Jul 31 '16 at 17:47
  • I think you'll need an answer from someone who has CS4 - sorry I can't help more – tomh Aug 1 '16 at 8:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.