0

I'm trying to merge 8 audio (.wav) files with a video (.mp4) file. I have the following command:

ffmpeg -i video.mp4 -i audio1.wav -i audio2.wav -i audio3.wav -i audio4.wav -i audio5.wav -i audio6.wav -i audio7.wav -i audio8.wav -filter_complex "[1:a][2:a]amerge=inputs=2[a0]" -filter_complex "[3:a][4:a]amerge=inputs=2[a90]" -filter_complex "[5:a][6:a]amerge=inputs=2[a180]" -filter_complex "[7:a][8:a]amerge=inputs=2[a270]" -map 0:0 -map "[a0]" -map "[a90]" -map "[a180]" -map "[a270]" -c:v copy -c:a:0 libfdk_aac -vbr:0 5 -c:a:1 libfdk_aac -vbr:1 5 -c:a:2 libfdk_aac -vbr:2 5 -c:a:3 libfdk_aac -vbr:3 5 -movflags +faststart output.mp4

I can successfully run the command and the output is good, but i get the following warnings displayed (3 times each):

[Parsed_amerge_0 @ 0x7fcaca708da0] No channel layout for input 1 [Parsed_amerge_0 @ 0x7fcaca708da0] Input channel layouts overlap: output layout will be determined by the number of distinct input channels

And:

[libfdk_aac @ 0x7fcacc87c800] Note, the VBR setting is unsupported and only works with some parameter combinations

What do they mean and how can i "get rid of them"?

Thanks!

0

The first warning means one of the WAV inputs has no channel layout defined i.e. channel 1 is Front Left, channel 2 is Front Center..etc. amerge decides the channel layout of the output stream based on the input, but since that designation is missing for one of the inputs, amerge will assign a channel layout which is default for the number of channels present in the output.

One thing you could try is rewrap all of the audio inputs i.e.

ffmpeg -i audio1.wav -c copy audio1-new.wav

The 2nd warning is displayed whenever VBR mode is invoked. Unless you get the error: Unable to set the VBR bitrate mode, you should be fine.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.