1

I have created a video using FCPX using media from my GoPro and my Cannon camera, when trying to export the video I receive an error "Project has missing or offline titles, effects or generators".

enter image description here

I have identified the clips which are still used from external sources, however when reimporting clips as instructed nothing happens.

enter image description here

The files aren't imported, I'm stuck on how to export this file. I have tried disconnecting and reconnecting the media (the footage is still able to relink itself) but doesn't import. I have also tried restarting FCPX but that hasn't done the trick either.

UPDATE: Actual error message when exporting... enter image description here

0

The error you are having "Project has missing or offline titles, effects or generators" is kind of self explanatory, the project you are trying to export is missing on of the following from within the project timeline

  • Title (some text you have put on or used)
  • Effect (a fade in or fade out, wipe, etc)
  • Generator (any one of the build in generators)

so if you watch the project from start to finish you will see the issue, somewhere on the timeline there will be a missing

If you have not used any of these then there might be something wrong with the project and I would suggest re-doing the whole project again.

I don't think you have any problem with the "media" as such. Normally within FCPX you will see a "red" section where there is a problem.

|improve this answer|||||
  • There are no red sections in my timeline. And all text and effects used are those that came with FCPX out of the box. The only issue I can see is some clips still display the camera icon (attached in post above) which to my knowledge indicates the footage is from an external device. – Imran Jun 3 '16 at 9:31
  • It might be worth removing all "Text, Effects, Generators" etc to see if the issue still appears. if the media was not available you would not be able to play it and it would just display a red box saying media offline. – Adam Mann Pro Jun 3 '16 at 9:40
  • Please check updated post, it is definitely the camera footage. – Imran Jun 3 '16 at 21:25
  • That will be due to the footage being used is on the camera and has not been imported into fcpx. You would need to import he media onto your Mac first and then export. To check unplug the camera and play the timeline and you should see what footage is missing – Adam Mann Pro Jun 4 '16 at 11:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.