I am new to AE, and hope this question makes sense for you and is easy to answer.

On my website I have some images in portrait format with 2085 × 2560 px. Now I will add a mp4 video file, which will be a simple animation of a logo.

The problem is that the exported file is not in the desired format (2085 × 2560 px); the width seams to be correct but the height is smaller than 2085px.

video smaller than the right portrait format image

this was the first try

I tried out different Pixel Aspect Ratios and different data for the height; unfortunately I just could not achieve my wanted result.

What do I have to do to get a video which has the exact format like a 2085 × 2560 px image? Or did I something wrong while exporting?

Thanks in advance!

  • 1
    If you're using the H.264 codec, you will need your dimensions to be even, so either 2084x2560 or 2086x2560.
    – Gyan
    Commented May 19, 2016 at 17:18
  • Yes I was using the H.264 codec, and I have realized that is was not possible because AE was warning this: "Warning: Output file will be resized from 2085 x 2560 (1.0 PAR) to 2000 x 2000 (1.0 PAR) to meet format constraints." So I tried out the MPEG4 codec, and it worked as I wanted.
    – Zararsiz
    Commented May 20, 2016 at 10:16

2 Answers 2


I just found out how to solve my problem. The H.264 codec is the issue, it somehow does not work with it and AE gives you a warning: Output file will be resized from 2085 x 2560 (1.0 PAR) to 2000 x 2000 (1.0 PAR) to meet format constraints.

enter image description here


I went with the MPEG4 codec and it worked as I wanted.

  • Did you test if the file works in a browser?
    – Gyan
    Commented May 20, 2016 at 10:28
  • @Mulvya, yes, I converted the mov file into a mp4 file and it works well on the website. Here is what I'm using: <video class="wilb" width="100%" autoplay loop muted> <source src="http://###.com/wp-content/uploads/2016/Comp-1.mp4" type="video/mp4"> </video>
    – Zararsiz
    Commented May 20, 2016 at 14:08

Update : Try this, precompose all the layers so you have only one layer remaining in the time-line. Then resize your comp with even numbers only! (2,4,6...) in your height and width composition settings. Apply the same height and width to the layer's scale. Now, it should go with the H264 codec as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.