3

I have a sub-3-minute sequence in Premiere CC, containing a single 4k DCI 23.98 AVC stream from a Sony FS7, with a couple static PNGs and 29.97 Quicktime Animation lower thirds.

I need to export to a quicktime wrapper around some sort of mpeg-4 codec; I've tried several configurations of H.264 and MPEG-4 with the same result.

My timeline plays and looks normal, but after export, I see the following result via Imgur videotogif:

http://imgur.com/I27CHk5

Because I know some of you will ask, here is a screenshot of my export settings:

enter image description here

Changing resolution, codec (within variants of Quicktime), with/without previews, max render quality - all has no effect on the strobing issue.

Anyone have any thoughts on what the problem might be here?

I'm having the same issue with a visually similar sequence in the same project for the same client, and had it once before as well (you guessed it, same client, same content specs). I've never experienced this ever before so I'm inclined to think there's some little gremlin in there somewhere - but I'm dashed to figure out what it is.

[edit]

I've also verified that the issue occurs when exporting to P2/MXF as well as ProRes.

Per @Mulvya's question about source properties, here's a screencap of the properties window on one of the clips. All the footage was shot in the same session, same camera, etc, and should be completely identical:

enter image description here

  • What are the source footage properties? – Gyan May 12 '16 at 19:18
  • Edited post with details. – mike.thorn May 12 '16 at 19:29
  • Can you export as an image sequence and check? – Gyan May 13 '16 at 6:49
  • I have the same problem, but after several exports, for some reasons, it happens inside premiere now.... – Elias Bendix Nov 30 '17 at 0:00
1

Are you using the "Mercury Playback Engine GPU Acceleration (CUDA)" as your renderer inside of media encoder? I've read about and had a few cases where software only rendering can cause similar issues.

  • So @NataliePi was on the correct track. I ended up poking a few other buttons the next day and, on a hunch, switched off CUDA-accelerated encoding. Boing, black frames gone. I'm working from a 2014 MBP Retina, which has dual graphics chipsets (Intel Iris Pro and Nvidia GeForce 750M). Since the results so were so consistently happening about halfway through the video, and only on frames being recompressed from original source, I wondered, as Natalie did, if it was a graphics card issue. Switching to CPU-only solved the problem. – mike.thorn May 16 '16 at 13:59
  • I'll reconfirm the issue when my Akitio eGPU box arrives (along with my shiny new GeForce 1070 in June) and have the firepower to determine if it really was a VRAM, or CUDA-related issue. – mike.thorn May 16 '16 at 14:02
0

My suggestion would be to forget the idea of exporting a Quicktime from Premiere using the H.264 Codec. The reason? Because it typically doesnt work.

The only sure-fire output module for Quicktime is the Animation codec; which will result in very very large files, if you export at 100% quality (essentially uncompressed) and especially so if you use an Alpha Channel.

Is there any reason why you need Quicktime as your actual wrapper?

I would highly suggest using:

Format: H.264 (Not Blu-Ray just H.264).

Setup the output to match your desired settings.

Set a target bitrate to meet your needs (for BluRay quality 1080p = 30mbps on average).

ALWAYS use CBR. Avoid VBR at all costs. Why? 1.) Time, VBR takes a lot more time, especially on a two pass. 2.) VBR will cause artifacting on fast flashes, such as a camera flash going off in frame, or just a white flash you've added in. The VBR engine first scans your video to approximate how to apply the bitrate frame by frame. When a camera flash is encountered (the frame goes near to all white), the preceding and following frame will suffer, because Adobe's algorithm for computing the adjustment will not adjust fast enough. It will drop your VBR very low for the white/black frame, but not ramp back up fast enough before or after that frame (which requires little if hardly any bandwidth).

CBR will ALWAYS give you a rock solid consistent output quality.

**So; as far as the black frame drops, forget Quicktime. Forget Quicktime forever, unless you require lossless output with an alpha channel using the Animation codec- never use Quicktime again. Instead:

Output as format: H.264 with the extention .mp4. After you have rendered out, if your client wants or demands an MOV file... - just change the extension to .mov and don't tell them. They will never know, the difference. Nor will any application they use to read the file see that it wasn't output using QT. It's H.264. The extension does not matter. Rename to .mov and boom it's now QT.

Simple as that. Remember Quicktime is just the wrapper - and a terrible one at that. H.264 is the codec. If it's H.264 they want, its H.264 you'll give them. It makes no difference if you name it movie.mp4 vs movie.mov.

So give that a shot, and I think your black flashes will be gone.

Again, the only valid use for Quicktime is the Animation output codec, which is great. Other than that, Quicktime is a dead format tied to a long dead OS.

The only time I ever use QT is in After Effects, for output of all comps before taking them into PPro for H.264 mastering. That is the only time I --ever-- use it.

Give it a shot.

  • This doesn't address the OP's problem, since it happens even when exporting to MXF in a different codec. – Gyan May 15 '16 at 16:36
  • He stated: "I need to export to a quicktime wrapper around some sort of mpeg-4 codec; I've tried several configurations of H.264 and MPEG-4 with the same result." I told him what I would try. Forget the wrapper. Get the H.264 out. then just name it as an MOV. MXF is even more problematic. – McFlySoHigh May 15 '16 at 16:44
  • Looking at his settings, also, there is no need to add keyframes every 1 frame. Add a keyframe every 30 frames. More than enough for seeking. – McFlySoHigh May 15 '16 at 16:45
  • 1
    You missed this - "I've also verified that the issue occurs when exporting to P2/MXF". This has nothing to do with the container. – Gyan May 15 '16 at 16:55

protected by Community Nov 30 '17 at 1:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.