I was wondering if anyone can help me? Whenever I uploaded a video to Youtube. I always get this message…(videos would upload faster if you have the right settings for your video). I think I doing the right rendering settings for my video in Wondershare Filmora.

Here are my render settings:

Encoder: Mpeg4 or H264(HD Optimized)

Resolution: 1920 x 1080 pixels

Frame Rate: 29.97

Bit Rate: 8000 or 10000 (My video bit rate usually says 32189)

Audio Bit Rate: 128kbps

Channel: 2 Stereo

Audio sample rate: 48khz

One of my videos information:


Resolution: 1920 x 1080 pixels

Frame Rate: 29

Bit Rate: 32189

Channels: 2 Stereo

Audio Bit Rate: 134kbps

Audio sample rate: 48khz

  • So what happens if the video is completely uploaded, does it look ok? It so, I think there is nothing you have to worry about except for this "wondershare" thing I have never heard of which apparently does a really bad job of reaching your target bitrate. Mar 30, 2016 at 20:19
  • There are plenty of great freeware video encoders, maybe take a look at "handbrake". handbrake.fr Mar 30, 2016 at 20:20
  • The video looks fine to me. Also, I've Cyberlink Powerdirector 12 installed on my laptop including Adobe Photoshop CC. I sure you know about video editing in Photoshop. I'll check out handbrake. Mar 30, 2016 at 21:11
  • The sinc message is typical when music track is not the same length as your vid. Ignore it.
    – Gerry
    Mar 1, 2017 at 17:21

2 Answers 2


What that message likely indicates is that the MP4 produced by Filmora does not have its MOOV box at the beginning of the file. The MOOV box has metadata about the audio and video streams contained in the MP4.

Why this matters is that Youtube speeds up processing by breaking the uploaded video into segments, processing those segments in parallel, and then joining the processed parts into a whole video again. If the MOOV box is at the front of the file, Youtube is able to start creating the segments and dispatch them for encoding as the file is being uploaded. If the MOOV box is at the end of the file, it has to wait for the whole file to be uploaded before it can start processing.

A cursory search did not reveal how to get Filmora to place the MOOV at the beginning of the MP4.

  • Hmm, that interested. A person I know used a software that wasn't Wondershare Filmora but he got the message. I don't remember the software he used. Apr 1, 2016 at 7:14
  • Any MP4 without a MOOV box upfront will trigger that message. Doesn't matter which software produces such a file.
    – Gyan
    Apr 1, 2016 at 7:15
  • What software do you use? Apr 1, 2016 at 7:16
  • Sony Vegas Pro and Adobe Premiere Pro CC.
    – Gyan
    Apr 1, 2016 at 7:20

I am not entirely sure how YouTube determines you are using "wrong" settings but as long as your video doesn't take a horrendous amount of time to upload and it appears to be fine on YouTube, I wouldnt worry about that message. Your settings look ok to my eye. The only thing that is off, is that this wondershare software seems to ignore your bitrate setting since the actual bitrate of the output file is much higher than what you apparently set as a target bitrate. This is no problem though since YouTube always recompresses uploaded files.

  • Okay! I will try not to worry about that message. Anyways, I just download Handbrake. Do you know of any tutorials on how to use Handbrake? Mar 30, 2016 at 21:51
  • this might be helpful for you, if not there are plenty of tutorials on youtube youtube.com/watch?v=2hmV7g6WTV4 Mar 30, 2016 at 21:59
  • Thank you! Just a question. Hopefully, you can answer it. I did some test videos in Cyberlink Powerdirector 12. I uploaded them to Youtube and got the same message. Mar 30, 2016 at 23:12
  • I've looked at some tutorials on how to used Handbrake. I have followed them and did some tests. Now, I received a message about the video audio being out of sync. Just trying to figure it out. @Hans Mar 31, 2016 at 5:37
  • Again, if your video plays fine - obviously keep an eye open if audio and video stay in sync - just ignore that message. Mar 31, 2016 at 5:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.