1

I recently made a video 3 minutes long with trapcode particular, 2 light layers and some simple expressions for particular (wiggle and time). Rendering in quicktime h264, 1080p 30fps.

I started to render the video and on first it showed 28 minutes remaining. I was extremely happy with that. Came back 30 minutes later and now it was estimating 1h 20 minutes. Came back hour later and now it was at 1h 54min. Although the rendering was now going for more than hour. The time kept increasing.

I decided to stop and use adobe encoder, with h264 and matching video settings high bitrate. Encoder at the start gave me 1hour and later increased that again.

So few hours later I am using after effects built in rendering and time remaining is 1hour 30 min and elapsed is at 3hr 44min and more than half way through rendering.

How could it be increasing all the time? I am using after effects for about a month now so I don't know all the hacks. I am using intel i5-6400 2.7ghz with 8gb of ram and 4gb of ddr5 gpu geforce gtx 750 ti.

Would it help if I would render particles separate with alpha channel and then add it to full composition? Would that reduce time?

Sorry for such bad explanation. English is not native for me.

  • Often when you hit a render time wall like that, where the time per frame keeps increasing it's because you've run out of physical RAM and the system is paging out to disk (thousands of times slower). Check to see if you've run out of RAM. – stib Mar 1 '16 at 1:29
  • @stib I rendered again just to see if there is any changes to make render faster. After letting it render for an hour after effects only used 2.5gb of ram. Which I think is nothing and it could use more. I did set it to leave only 1.5 for other software. Also my cores are not fully used. They are at 50% on average. How could I make it to like 90%? I am using SSD to save files and run after effects. – mypoint Mar 1 '16 at 19:36
1

I usually export as a ProRes Quicktime movie from After Effects directly, then convert my ProRes file to h264. I keep the ProRes as a master file, and compress the h264 as needed. Also sometimes restarting AE before rendering fixes any slowdowns. If the particles are using large (greater than 200x200 pixel) layers for their textures, this will make things render very slowly.

  • Could the slowdown be also because I am using expression? Or it does not affect it much. I have applied expression to velocity and particles per second. – mypoint Mar 1 '16 at 19:33
  • It could do- depends what the time expressions are doing. Did you try a pro res render instead f h264? Tends to be quicker in my experience. Also how many particles are we talking about? Are you applying textures to them? – tomh Mar 1 '16 at 19:44
  • Expressions are pre-calculated I believe. So if there are heavy expressions in the comp it takes a while before it starts rendering. You could try converting all the expressions to keyframes to test whether it's the expressions. I agree with Tom: rendering to h.264 isn't the best way to go, because h.264 uses inter frame compression each frame is dependent on lots of other frames, which makes it slower to render. – stib Mar 1 '16 at 20:20
  • @tomh I am not applying texture to them, but I am playing around with setting when each particle emit particles. I think it was aux settings. I have set it to to 1 particles per second, but I think because each particle emits another particle is the reason why it's slow. – mypoint Mar 1 '16 at 20:52
  • @stib I will give it a go tomorrow. – mypoint Mar 1 '16 at 20:52
-1

Pre rendering comps is useful if the items in the pre render don't need any more tweaking. So if you're still working on the overall project but the particles are finished, maybe I would pre-render them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.