I want to be able to receive push notifications to my iPhone when After Effects completes a render.

I used to use Prowl v1.5.2 & Growl v2.1.3 combined with this script (.jsx file)to do this, but I can't get the script to work now.

I can get growlnotify to send a notification from the terminal to Growl, and successfully pass it to Prowl on my iPhone, but when I tried this script, it fails at line 24. I've added the API key, and chosen growl as the notification type. Growlnotify is in usr/local/bin and my appname is set to Adobe After Effects CC 2015.

I don't need background rendering, just a simple notify when renders complete.

I'm using OSX 10.11.1 and iOS 9.2, and After Effects CC 2015 v13.6.0.165

Here's a script example, it's only two lines:

function(){system.callSystem(“Open growlnotify")};

First line renders the queue (without any safety checking) Second line should open growlnotify to send a default message

First line works, second line doesn't - it returns "Syntax Error". I've also tried:

  • Maybe, paste your script (with the API key obscured).
    – Gyan
    Dec 15, 2015 at 14:36
  • Good idea - done.
    – tomh
    Dec 15, 2015 at 14:52
  • Can you use full path to invoke growl?
    – Gyan
    Dec 15, 2015 at 14:55
  • And I meant the script whose line 24 fails.
    – Gyan
    Dec 15, 2015 at 14:56
  • I've tried that, but it didn't work. From the terminal, I can invoke growlnotify from any directory.
    – tomh
    Dec 15, 2015 at 14:56

1 Answer 1


The script extract you include:

function(){system.callSystem(“Open growlnotify")};

has a dodgy opening quote. “ is not the same as " - this is why you are getting the syntax error.

(function(){system.callSystem("Open growlnotify")})();

works (the (..)() calls the anonymous function). You need to add the parentheses so that the anonymous function gets called, or simply do system.callSystem("Open growlnotify"); without the anonymous function.

You also need to activate "allow scripts to write files and access network" in Preferences/General, otherwise callSystem is blocked.

In the full script you post, when you replaced type = "web" on line 24 to use growl, the same error probably slipped in. Check your keyboard autocorrect settings to ensure that you've not got curly quotes.

  • Thanks - that is very helpful - it stops the syntax error! But I still don't get growlnotify running!
    – tomh
    Dec 17, 2015 at 9:51
  • But it does fix the Render_Notify_14.jsx file I linked to, so that works for me! Thanks again.
    – tomh
    Dec 17, 2015 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.