2

I am trying to edit 2.7k 60fps footage (shot with my GoPro Hero 4 Black) using Adobe Premiere Pro CS6. But even when I try to play a clip in the source viewer (i.e. before even putting a clip onto the timeline), I get a very laggy experience that feels like 2 frames per second. If I play the same footage in my OS's native media player (e.g. Windows Media Player or Quicktime) I get smooth playback without any visible frame drops. I have tried converting the H.264 compressed footage to Cineform digital intermediate, but this does little to resolve the problem.

I am aware that editing high resolution video is demanding (see, e.g., Adobe Premiere Pro CC editing/playback performance), but my question is specifically why does playing back raw, unedited footage perform so much worse in Premiere than in a dedicated media player when both are apparently performing the same task?


System specifications are as follows:

System 1: i7 950 at ca. 3GHz, 12GB DDR3, GeForce GTX 760 2GB, 256 OCZ Vertex SSD

System 2: 2013 MacBook Pro Retina, i77 2.7GHz, 8GB 1600MHz DDR3, GeForce 750M, 256GB SSD

I have the same issue on both systems.

  • Did you allocated enough RAM in Preferences => Memory? – Shultc Sep 20 '15 at 20:38
  • @Shultc On "system 1", for example, I have 7GB allocated for Creative Suite applications. Premiere is the only Creative Suite application I have running. – Ubiquitous Sep 21 '15 at 6:41
  • And how many RAM is used, when you are playing it with media players? Maybe try to maximize that number for test, and look, if that will help. – Shultc Sep 21 '15 at 15:02
1

I have discovered that this problem is specific to GoPro cameras from the Hero3 and range and later.

For Premiere CS6, the problem can be solved by updating to version 6.0.5. The update can be downloaded here. After installing this update I get flawless playback in Premiere and others have reported that this solution worked for them too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.