whenever I drag a clip across the timeline and place it on top of another, the entire thing or a portion of it gets deleted, how do I disable this feature?

(I know the general work around to do this is not to do it but I would like the security that if I missed that I accidentally dragged another clip on top of another and then deleting a little bit that it won't happen)

  • What about if you put it in a new track? So instead of dragging it onto the clips that are already there, you drag it above them.
    – stib
    Sep 2, 2015 at 12:14

1 Answer 1


There is couple solutions:

  • Use Alt+ Drag
  • Use Track Select Tool to move everything before and after dragging
  • Use Insert button (,) button from Source monitor

Good luck!

  • Yeah, that's exactly what I don't want to do! I want to disable this feature permanently. I don't want a work around Sep 2, 2015 at 12:09
  • Then just put some weight on your <kbd>Alt</kbd> button =)
    – Shultc
    Sep 2, 2015 at 13:06
  • @user3910035 Consider that this is not a forum, if Shultc solved your issue, please accept the answer for future visitors. Might be a good idea to start with the tour: video.stackexchange.com/tour.
    – p2or
    Sep 2, 2015 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.