I have two videos to combine in Adobe Premiere. They play okay in a video player, but putting them into Adobe Premiere CS6 suddenly makes the audio unsynced with the video (even in the Source Monitor).

The videos are:

  • 4GB each
  • 1080p @ 60FPS
  • 48 kHZ audio
  • Codec ID: avc1

Googling indicates this is a common problem. I've tried various fixes that did not fix the issue, such as renaming to .mov.

It records from NVIDIA Shadowplay. I suspect this has to do with the variable framerate. My goal is to keep them 60FPS.

How can I fix this so my audio & video are not out of sync? Even after exporting to a final clip, it's still out of sync.

[EDIT] I'm seeing mentions of using Handbrake to convert the source video first. Is there a way to solve this without having to convert every single video using Handbrake?


5 Answers 5


Download the 32-bit static build ffmpeg from here and try either of the two methods:

1) regenerate the timestamps

ffmpeg -i input.mp4 -c copy -fflags genpts new-input.mp4

2) Extract audio, import that separately, align starts in timeline and then check

ffmpeg -i input.mp4 -vn -c:a copy input-audio.mp4

I would strongly suggest that you don't work with mp4/H264 files for sync-sensitive work. Transcode the files and work with those.

  • 5
    There's nothing wrong with H264/MP4 for editing, including syncing work. I've done it hundreds of times.What you don't want is VFR or streams with many reference frames whose decoding requirements make editing sluggish or throws the NLE's decoder off. A baseline or even main profile CFR H264 stream will do just fine.
    – Gyan
    Nov 3, 2015 at 11:16
  • Nothing wrong indeed, but safer to work with codecs that are steady and reliable. h264 is really for reviewing. Nov 3, 2015 at 13:47
  • I only work with NVIDIA Shadowplay. How can I change what it outputs to?
    – Zeno
    Nov 3, 2015 at 15:12
  • Seems Shadowplay doesn't do constant framerate, so if my methods didn't work, conversion to CFR MP4 is your best option.
    – Gyan
    Nov 3, 2015 at 16:52

I had the same issue on Windows 10 with a Variable Frame Rate (VFR) video recorded using Shadowplay. Here's how I fixed it without requiring to convert the video using Handbrake or any other converter:

  1. Download Apple's Quicktime and install it
  2. Rename the .mp4 file to .dif
  3. Import that .dif file to Adobe Premiere Pro and it should not have any audio/video sync issues

I suspect it works here because Adobe Premiere Pro fails to load the .dif file without Quicktime installed meaning that it uses Quicktime's codecs etc. to deal with the file which can handle VFR. This means that the built in codecs Adobe Premiere Pro uses have an inherent issue with VFR.

For completeness sake, this should fix issues with all VFR MP4 files such as the ones created with Shadowplay, Xsplit, OBS, iPhone, relive etc.

  • oh my, this works on macOS! This is the golden answer!!!! Jun 14, 2017 at 12:07
  • Worked for me on Windows 7 64-bit when .mov wouldn't, thanks!
    – MC10
    Jul 21, 2017 at 23:24
  • This didn't work for me on Windows 10 with QuickTime 7. I had to re-encode my video using FFmpeg.
    – Ryan
    Jun 27, 2018 at 0:44

You're probably going to need to convert them. The following methods work for me on a Mac:

Convert them to ProRes 422 Quicktime files first before beginning to edit on them. Use something like Quicktime Player Pro if Adobe's media conversion is doing strange things.

Then open the converted files in Premiere.

Nudge the audio around until it syncs up at the beginning of the first video clip. Take a note of how far you had to nudge it to get sync.

Check the end of the file is also in sync. If it isn't, check the middle of the file... Keep working backwards until you can find out where the sync gets worse. Each time the sync gets worse, chop the region into two pieces, and re-sync the next piece manually.

It's boring, but it will work. If the number of frames out of sync is the same in each file, you'll have it done quickly.

Export as ProRes .mov files, then convert from that to whichever lossy format is needed for delivery (e.g. h264 quicktime .mov)


This works for me every time, if you're on windows, put the video into Windows Movie Maker (I know, just listen), after the video is in there, go to File> Save Movie> Recommended For This Project, it will re-save the file (even sometimes mp4 into mp4) try putting that new file in premiere. Guarantee it's going to work :)

  • 2
    Windows Movie Maker is not supported for Windows 10.
    – Zeno
    Aug 23, 2016 at 17:19
  • For those who have windows 10, here is the link. Download it and simply click on windows movie maker! go.microsoft.com/fwlink/p/?LinkID=255475
    – Spleffie
    Feb 1, 2017 at 12:17
  • 1
    @Spleffie "This site can’t be reached"
    – Zeno
    Apr 15, 2017 at 13:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.