1

I've been masking all day today and everything has worked perfectly up until now. I did my usual mask and then rendered it but upon render everything screwed up. I have tried it multiple times and I've even gone as far as to re-import the clip and mask it all over again. The results were different but only in the pattern of the glitch.

Im busy uploading the clips of the glitch right now so I'll just have to explain it for now. Basically everything looks perfectly fine in the ram preview window but when I render it, it separates the video around and the mask is completely messed up. Can someone please help me with this? It's incredibly frustrating when everything else today has gone smoothly. I'm using After Effects CC

Ram Preview Window:

enter image description here

After Render:

enter image description here

  • Welcome Ethan :) Hard to say. I'd suggest to check your matte only (create a black solid, copy your masks into the layer, create a white background, render it, import it with the correct frame rate settings). – p2or Jul 27 '15 at 14:34
  • Thanks but I fixed it by simply freezing everything :) – Ethan Jul 27 '15 at 20:01
  • Great! Can you please elaborate and convert this into an answer? – p2or Jul 28 '15 at 6:49
  • Having the same issue?? What do you mean you froze everything?? My subject is walking so cannot freeze it? – Leon May 18 '17 at 13:29
1

Once the Rotobrush tool has been selected to use (assuming you used Rotobrush based on the pink outline) a small box in the bottom right of the comp will appear and should say "Freeze." Literally just press that and it'll freeze the mask... fixed my masking render glitch and I hope it does for you too! Best of luck, happy editing.

  • By "freeze" it's important to note that it really means pre-calculate, not "freeze"-as in stop moving. As you work on rotoBrush, masks are calculated on the fly. When you go to render you need to have the masks pre-calculated or the render engine won't do the mask calculations properly. That's what the freeze button does. – stib Aug 13 at 11:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.