3

I have a wmv video file that was recorded using widows media encoder. However, while recording, the computer lost power and the video is was not "completed". The video will play in most player, however, it reads that it is 0:00:00 minutes long. So when I try to seek the video the player either freaks out and crashes or it won't do anything.

I tried loading the video in Vegas Pro, but it didn't work. Vegas Pro sees it as an infinitely small clip, rather than the whole thing. So I can't edit it either.

I was able to convert it to an Mp4 in handbrake, but now that I have to do some editing on that, I'm going to lose significant quality. I would rather not have to do this and just be able to find the index file.

What can I do about this? Is there a program or feature in some program that can reanalyze the video and give it a proper time index (if that's what this is called)?

1 Answer 1

1

I've had some success with ASFTools and Steeper WMV Repair. Both of these are older tools (Steeper is from 2005) so may not be able to handle later versions of WMV, but they're worth a try.

2
  • Yes, wonderful! ASFTools was able to fix it. Steeper was not. In ASFTools I first clicked on "Make Seekable", but then it suggested clicking on "Lost Chunks". That fixed it. Not sure what that means technically speaking, but it is now seekable and I can edit the original video.
    – user3643
    Jun 1, 2015 at 16:31
  • If you know and understand the technicals of how this works, please consider answering my next question: What was technically wrong with this unseekable wmv?
    – user3643
    Jun 1, 2015 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.