3

I'm trying to import some clips into a Vegas 13 project, but they "flicker": some frames are all black (even in the preview), even though the files play perfectly in mplayer and VLC.

The clips are recorded from a videogame using fraps, and then reencoded in H.264 with mencoder with the settings: -x264encopts preset=slow:keyint=200:crf=19:level_idc=31:colormatrix=bt709 (I don't have the originals anymore, I deleted them to gain disk space. Stupid mistake, I know).

Gspot tells me this about the files: enter image description here

I have tried a lot of different options:

  • disabling using the GPU for rendering
  • setting the switch to "smart resample", "force resample", and "no resample"
  • changing the frame rate
  • using constant and variable bitrates
  • using the "deinterlace" settings "blend" and "interpolate" (pretty sure this does nothing in my case ^^)
  • checking/unchecking "adjust source media"
1

While I wasn't able to fix the problem, I was able to go around it, by converting my input file into xvid.

I don't have any black frames anymore, but the video freezes for a few seconds at some point.

Since I was recording and playing the game on the same PC, I'm guessing that there's been a problem at some point and fraps had to drop the framerate.

In any case, I suspect some other bug in my video editing setup, since Vegas was adding black frames in other parts of the video, that play fine once converted to xvid.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.