3

I had an image in my After Effect Composition. I want to rotate the image by time with out any disorder in its shape.

When I am trying to rotate image a shearing effect is happening. How to resolve this issue, so that there will not be any shearing to image while rotating.

Below I have attached what happening now when I am trying to rotate.

  1. Default Image : 0 degree rotation. enter image description here
  2. Transformed image : 42 degree rotation. enter image description here
  • Scale is locked to proportional? – p2or Jan 29 '15 at 19:34
  • Even when scale values are locked and unlocked, I am getting same effect. Sorry I didn't checked before commenting. I will update my screen shots with scaling options settings. – Dipak Jan 29 '15 at 20:07
6

Make sure scale values are locked and set both to 100%:

enter image description here

  • This is it. Scale Default size in locked state, then rotate. Thanks. Lots of confusion in-between. Thanks. – Dipak Jan 29 '15 at 20:25
3

Is that composition a 16:9 composition with non-square pixels? looks like it. Check your composition settings, particularly the pixel aspect ratio setting.

enter image description here

If your pixel aspect ratio is not Sqare Pixels then the comp is set up to display correctly only when it is stretched. This is the way DV video and DVDs do 16:9 while still having the same pixel resolution as 4:3 video. When you render and play it in a player there is metadata in the file that tells the player to play back with the stretching, so that it looks ok. But AE displays it without the stretching unless you turn on Pixel Aspect Ratio Correction.

You can turn Pixel Aspect Ratio Correction on in the composition display window with the little icon at the bottom of the composition window

enter image description here

or from the menu View > View Options…

enter image description here

What it looks you're doing is stretching the individual elements in the comp to make them look right. This won't work if you then render out with non-square pixels, or as you've noticed if you rotate them.

  • My Pixel Aspect Ratio is HDV 1080/DVCPRO HD 720 (1.33) And, Frame Aspect Ratio is 16:9 (1.78). I cant able to find out the icon in composition window to make Pixel Aspect Ratio Correction, so I tried with menu, in menu the view>view options is in disabled state now.How can I activate this option. – Dipak Jan 31 '15 at 5:06
  • 1
    You have to have the composition window open and active (the blue border should be around it). Just click somewhere in the composition window to activate it. – stib Jan 31 '15 at 12:19
  • This what actually my problem. Pixel Aspect Ratio Correction. Thanks man. PS: I am changing this as accepted answer. – Dipak Feb 1 '15 at 7:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.