2

I have two (rgb) jpeg sequences one with the alpha information (black and white) the other one with the green screen footage. I keyed them with Keylight and they look perfect in AE before exporting.

key

When I import the jpeg sequences back in AE and apply the alpha, I get a green hallow.

premult

It seems to be some premultiplication issue. What did I do wrong exporting / importing the jpeg sequences?

greenscreen alpha

  • Do you've tried another format like png/tga with alpha? – p2or Jan 29 '15 at 12:01
  • 1
    I have tried exr with an alpha. Same problem in nuke! I need it as a jpeg format though. – Benedikt Jan 29 '15 at 12:03
  • You need the jpg alpha's for creating an alpha channel in nuke, right? Unfortunately can't test it at the moment. Can you provide an image to test with? – p2or Jan 29 '15 at 12:05
  • Added test footage. I need it for 3ds Max but it would be nice to know what to do in After Effects or Nuke. – Benedikt Jan 29 '15 at 12:33
  • 1
    Looks like you need to use a spill suppresser to kill the green in the areas where the alpha channel is not 100%. – stib Jan 30 '15 at 2:34
1

Part of it may be the fact you are using JPEG sequences. JPEG isn't a pixel accurate format and you are going to have some differences in block quantization that could potentially result in mismatches.

I don't think that is the only issue since it is a bit too regular for it to be the only issue, but I'd try to use an intermediate format that is a bit more lossless for doing things that need to be pixel accurate match up.

| improve this answer | |
  • It has the same problem with a multichannel exr. So the jpeg shouldn't be the issue. – Benedikt Jan 31 '15 at 12:46
1

The problem is that my alpha Mask has a feather. Which results in greeen peaking through the Mask. So the only solutions are export an alpha mask with no feather or export the original image with a black or desaturated background.

Feather

| improve this answer | |
  • I'm still wondering though, why it does not have that problem when it is still in After Effects. I guess Keylight automatically desaturates the green on the semitransparent areas of the Alpha. – Benedikt Jan 31 '15 at 12:45
  • If the feather is properly positioned it shouldn't matter, but if the feather is too far out it would be. You could try upping the edge growth or whatever the equivalent setting is to move the feather in to keep a soft edge. – AJ Henderson Jan 31 '15 at 15:20
  • What I'm wondering though is why it looks ok in After Effects though. – Benedikt Jan 31 '15 at 19:12
  • I'm not an expert at this, but you might be running into a problem because of working in a non-linear colorspace. IDK if that's even the right term, but I've seen ffmpeg docs or something say something about color spaces being linear or not. I assume that means something like alpha blending will suffer from color shifts if done naively (new = alpha-weighted sum of all inputs) in a non-linear colorspace. So that's what you should google if you want to maybe figure out what Keylight did. – Peter Cordes Feb 3 '15 at 21:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.