1
Camera
[comp 3D]
  ellipse mask in z-axis
  layer1 2D
  layer2 2D
  layerN 2D

The layers are aligned in the Z-axis along the ellipse, forming a 3D text by the layers. When I'm inside the composition, I can actually see a aligned layers in the 3D space.

But when I go to my main project view just seing the "comp 3D" layer, everything is plain 2D! Also moving the camera I can just see a plain 2D image, even though inside the comp it is 3D. Why?

Update: enter image description here

There are 3 lights being aligned differently in the z-axis (see TOP view).

When I move a camera around inside the "light comp", everything is fine and I can see also my lights moving.

When I move the camera in my main layout, the lights are static! No movement is reflected to the light comp layer! I can just see the camera mask moving, not the comp content.

1

The issue could be Optical Flares, it doesn't fully integrate into AE's 3D space but has its own coordinate system. The usage of AE lights is somewhat of an workaround for that. Have a look at this plugin/script, that could help: http://www.videocopilot.net/tutorials/3d_pre-compose_script/

It's exactly made for what you want to do.

  • OK so you're saying I have to keep a copy of my camera and especially of all my lights in my main as well as in my composition? – membersound Dec 30 '14 at 18:04
  • I assume it's not necessary to keep any lights or layers targeting the optical flare stuff in the main view. The important fact is the camera link with all it's properties here. And it works! – membersound Dec 30 '14 at 19:33
  • 1
    Exactly, you just need to link the cameras. Everything else is for more advanced effects. – PTS Dec 30 '14 at 21:35
2

You need to click the Collapse Transformations (sun icon) on your [Comp 3D] layer. Otherwise your main comp will treat your other comp as a flat layer in a 3D space, if that makes sense?

enter image description here

  • If I do so, and move my camera, I'm just seeing the camera mask being moved, but not the precomp layer, which remains still. Will I have to make the camera animation inside the precomp? That would not make much sense. But no matter how I move the cam that is on the same level than my precomp, there is not layer movement. – membersound Dec 30 '14 at 12:03
  • I think all the layers in your precomp should either be 3D or 2D. I think the problem is that you're mixing 3D and 2D layers. In your main comp you have a 3D camera, and it won't be able to correctly render both sets of objects unless the 2D objects are in your main comp. (the camera movement will not affect the 2D objects - and you wouldn't want it to). – tomh Dec 30 '14 at 12:10
  • Hm, the problem is my layers are mainly lights, which are 2D be design and cannot be switched to 3D. Anyhow these lights are distributed along the 3D space inside my precomp. So, I cannot make my layers 3D, anyhow the are aligned in 3D and the cam outside the precomp should be animated in that space. – membersound Dec 30 '14 at 12:30
  • When you say they are lights, are they created by going to the Layer -> New -> Light menu? All lights are 3D by default. All items in a 3D space need to have the 3D cube icon enabled. Maybe post some screenshots of your project to give a clearer idea? – tomh Dec 30 '14 at 12:48
  • please have a look on my updated image – membersound Dec 30 '14 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.