0

I'm working on the RTMPT server. Seems, that all done correctly, tcpdump's logs shows no difference with Red5. Flash Flowplayer successfully passes handshake, creates and starts stream, initializes metaData, but playback doesn't starts.

I tried to sent exactly the same data as Red5 (dumped with tcpdump), but the result was the same.

How it can be? What am I doing wrong?

Thank you!

Just ask if you need more information.

Dumps:

http://79027.selcdn.com/stuff/capture_rtmpt_h264_live_red5_baseline.cap (working, red5) http://79027.selcdn.com/stuff/capture_rtmpt_proxy.cap (working, red5 through custom proxy) http://79027.selcdn.com/stuff/capture_problem.cap (wrong; my implementation)

P.S.: video is in h264.

  • You may have better luck with this on SuperUser or ServerFault. In depth configuration of RED5 is really more server related than video production related. – AJ Henderson Dec 18 '14 at 15:08
  • @AJHenderson but this question is not about configuartion but about development. – yttrium Dec 18 '14 at 15:16
  • That likely makes it even less on topic here I'd think. RED5's "development" is really more configuring end points though than I would really consider it development. – AJ Henderson Dec 18 '14 at 15:40
  • @AJHenderson but where I should ask this? And this is NOT about "RED5's development", the question is about implementing custom RTMPT server in C++. – yttrium Dec 18 '14 at 15:48
  • Probably stack overflow then. I would suggest adding some code from around where the problem is first though. – AJ Henderson Dec 18 '14 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.