1

I have some white text that fades out on a red background (rgb (255,0,0)) in After Effects.

For some reason, in After Effects, the effect of the text fading out is a dark, almost 'black', animating with Opacity:

Screenshot - After Effects

Whereas in Photoshop, the red 'comes through' the text, resulting in a reddish, transluscent white:

Screenshot - Photoshop

What am I missing? I'm confused why a '20%' white Text Layer on a Red solid would end up being black/grey in After Effects?

EDIT This problem disappears when turning off the Layer Style, which is a simple Inner Shadow with the following settings:

Blend Mode: Multiply
Color: Black
Opacity: 75%
Use Global Light: Off
Angle: 0x+120,0°
Distance: 1,0
Choke: 0,0%
Size: 1,0
Noise: 0,0%

--

So I suppose, why does a simple layer style cause everything to go black when reducing opacity of the text layer?

Adding image to demonstrate:

AE opacity issues

  • It is probably something weird about your blending mode, but you don't have enough detail here for me to be certain. – AJ Henderson Oct 6 '14 at 19:51
  • @AJHenderson I've added some more detail in case it helps – waffl Oct 7 '14 at 11:56
1

I think it seems like you have added layer style to the text in Photoshop. The text in the photoshop has Bevels & Emboss. From this point, you may have some other effect added on this text layer. I tried myself with same red background and same white text, here is what on my computer: Test in Photoshop

Here is what it looks like in AE of 20% opacity: Test in After Effects(20%)

And here is what it looks like in AE of 40% opacity: Test in After Effects(40%)

So I think, it's only about how the software distribute the percentage of opacity, in After Effects, you should assign a higher opacity to the layer. I don't think there is a wired problem that in AE that you got a dark layer as you stated.

Hope this may help :)

  • Hi, the effect I'm using in Photoshop is just Inner Shadow, and in After Effects, I have used the same settings with a layer style. Turning the layer style off produces the right effect, but then I'm wondering why a simple 1px inner shadow would cause the entire layer to be 'black' when it is less opaque? – waffl Oct 7 '14 at 11:50
1

I think the layer styles cause AE to render slightly differently - they don't work with every plugin for example.

Have you tried precomping the text with the layer style, and doing the opacity adjustment in the outer comp?

I also think it could be because the layer style you're using has a multiply function within it. Maybe try switching the display mode in the layer style to Normal, and see if you can get the same effect..

Finally, could it be something to do with working at full saturation red (255,0,0)? When I render videos out, full reds tend to look pretty horrible as video files...

  • Yep, it's definitely the layer style, and precomping is the solution. – stib Oct 9 '14 at 11:39
0

Most likely the issue is one of resolution. It is quite possible that your original photoshop layer was being displayed at much higher resolution, so a 1px border wasn't that noticeable, when changed to a layer on a low resolution video frame (1080p video is only 2 megapixels), 1px is suddenly a much more noticeable level of adjustment. The entire surface of the text doesn't have to be dark, only the outside edge. If we see a dark border, our eyes tend to automatically see the enclosed area as slightly darker, so that may explain it.

Additionally, I don't know that the fine points of blending and layer styles are exactly identical between Photoshop and After Effects. They are different programs with different features and optimizations. Adobe tries to keep them pretty similar to allow for interfacing between applications easily, but it still isn't the same program. Some aspects do actually use the other programs to use functions, but I'm not sure if layer blending and stlying is one of them. I've occasionally noticed other layer blending issues changing slightly, so this isn't entirely unexpected when using advanced features like styling.

  • Hi AJ, thanks for the response - my PSD is exactly the same resolution, 1920x1080. At 100% opacity, both AE and PS display identically, it's only when adjusting opacity that the issues appear – so it's definitely something to do with the way AE treats transparency with layer styles, how strange. – waffl Oct 7 '14 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.