Since installing Miraizon DNxHD / ProRes Codec I am not able to play my timeline in real-time. It gives me a few frames and then the video freezes and audio keeps playing. I changed from Performance mode to Memory mode and now it will play through, however if I stop and start a couple times. It reverts to the former behavior. Specs of my system and project below.

I have Premiere Pro CC 2014 on a Windows 8 PC i7-4930 16GB RAM. Drive structure: Win/Programs on 256GB SSD, Project/Media on 1TB SSD, Preview/DB on 5TB RAID 0 7200 Seagates.

I'm working on a shortform project, basically 5 sequences comprising 18mins of a 22min show. Two streams of prores from from a 5D,6D 2 cam shoot, and I'm putting slides, stockfootage, and titles in.

I was able to play my timelines in real-time just fine (preview format DNx 115 1080p 23.976) until installing Miraizon DNxHD / ProRes codec. I got it because the editor putting the final show/QC together is on FCP7.. anyhow after installation I notice my preview files were gone -not surprising-. If I delete my preview files I get a couple clean playbacks (after they regenerate) and then the original behavior, same if I restart PPro.

I tried running the QT installer and "repairing" that after someone suggested that the QT SDK might be the issue. No difference. Makes more sense to re-install DNxHD codec from avid probably- I'll do that next.

Has anyone had a similar issue or Can you suggest what might be going on?

1 Answer 1


According to Miraizon support this is a peculiarity in Premiere Pro handling of ProRes that causes it to interact "very inefficiently" with the the codec. There is an update forthcoming but until then they suggested this as a work-around: Move the AppleProResDecoder.qtx from the /Quicktime/QTSystem/ folder to a temp folder.

I still get some inconsistencies with various files under these circumstances such as "Media Pending" messages that aren't resolved and spotty playback. This is currently working for me: For editing: Leave the AppleProResDecoder.qtx in /Quicktime/QTSystem/ and move the MProResCodec.qtx from the /Quicktime/QTComponents/ folder to a temp folder. Restart PPro.
When I'm ready to export my ProRes: Then when I'm ready to export to ProRes, I move the MProResCodec.qtx back to the /Quicktime/QTComponents/ folder and move the AppleProResDecoder.qtx into the temp folder. Restart PPro.

  • Ah, ok, I wonder if it is related to the Quicktime embedding issues. There are some pretty severe issues on some systems with the old 32 bit quicktime engine that Premiere has to use for processing mov files. Sounds like this is probably hitting on that. Glad they had a work around to help it behave and thanks for sharing what you found.
    – AJ Henderson
    Commented Jul 25, 2014 at 20:57
  • In one project I get repeated Adobe QuickTime Server errors since installing Miraizon. But I can't centralize it, the project has a lot of linked PSDs and AEPs. But this "workaround" also helps with that. I still get the error when opening the project, but I can still export via AME -sometimes I have to break it into small sections and copy into a new sequence to avoid the error.. I assume some sort of memory problem.
    – integris
    Commented Jul 25, 2014 at 23:19
  • Thanks for that - your workaround does the trick and is quicker than uninstalling/re-installing the codec every time I need to switch between reading and writing ProRes. Still very frustrating and I wanted to add that I bought the update to Miraizon (version 2) and still exactly the same problem with Premiere. To offer ProRes on PC but not be able to use it effectively in the main editing software is somewhat of a major flaw in my mind....
    – user9092
    Commented Jan 8, 2015 at 10:24
  • They released an update this past fall (2014). The "memory issue" is better, but still seems to grind down after a (much longer) time of editing. Usable most of the time, but I don't experience if I follow the fix above.
    – integris
    Commented Feb 3, 2015 at 19:23
  • 1
    Thank you so much for this information. Editing a 4k collection of Mirazon ProRes clips in Premiere CC and I've been getting constant hanging, Media Pending, and green preview screens. Moving MProResCodec.qtx to a temp directory allows me to edit with buttery smooth playback. You saved my monitor.
    – user12770
    Commented Feb 10, 2016 at 6:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.