I have a video that fails to play in the QuickTime plugin in Internet Explorer on Windows 7, but it plays fine in the standalone QuickTime player. I suspect that this may be an encoding problem, and I wanted to ask the experts. I did not personally encode this video, but I am assigned to troubleshoot the problem. If it is, in fact, an encoding problem, I would like to be able to point to specific evidence.

The file: https://ptgmedia.pearsoncmg.com/digital/video/9781587143991/ccent_icnd1_media/video/0_0_0_0_0_icnd1_video_intro.mp4

A file that works (if it helps): https://ptgmedia.pearsoncmg.com/digital/video/9780321765147/9780321765147_01.mp4

  • 1
    Looks pretty standard, and nothing I tried it on complained. MediaInfo says there's a stream with ID #2 it calls "Menu". Could that be messing up IE? What is the failure -- does it play at all, or play badly (corruption etc)?
    – Jim Mack
    Mar 19, 2014 at 21:35
  • 1
    Have you tried it on more than one computer? My guess is something is wrong with the configuration of how IE tries to use QuickTime on that particular computer.
    – AJ Henderson
    Mar 19, 2014 at 22:22
  • @JimMack It doesn't play at all. I get a question mark over the QuickTime icon. I wasn't able to determine any way to access an error log or similar from QuickTime. Mar 20, 2014 at 13:23
  • @AJHenderson I'm able to play the video in many other ways. I'm trying to fix this particular use case not for me, but for other users who have this issue. A workaround is OK (i.e. use another browser, or download and open in QT proper), but a fix on our side would be preferable. Mar 20, 2014 at 13:24
  • @DustinRasener - I thought I mentioned it, but I see now I did not. I tried your link in IE and it works fine on my computer. My guess is that the problem is either the client or the way it is embedded. Are you able to include a link to where the video is actually embedded?
    – AJ Henderson
    Mar 20, 2014 at 13:29

1 Answer 1


Well the program that encoded the file that works was Apple QuickTime so not much of a suprise that it's working. QuickTime can be a little picky when it comes to mpeg4/h264 encoded files. I looked at the files and possible factors are the encoding profile and maybe the GOP setting. Basline Profile Level 3.0 for the broken one and Main Profile Level 3.1 for the working one. GOP setting of M=1, N=120 and N=1 for the broken one. Could be that the Quicktime Plugin wasn't made to handle that.

An easy fix would be to re-encode it with Quicktime Pro or the free and open source tool Handbrake http://handbrake.fr/ and choose one of the Mobile presets for apple devices or simply the "Normal" preset.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.