Tag Info

Hot answers tagged

3

No this is not possible. Looking at this theoretically disregarding the codec you can not take away information and call it lossless, thats already a terminology problem. Applying a new color space without transcoding is also not possible It's not so easy to say whether this is even possible with certain codecs other than h264, it really depends on how you ...


2

If you copied your command there then your issue is probably -acodec:0 mp. That should be -acodec:0 mp3. You can just use -c:a mp3 to apply the encoding options to all audio tracks at once, no need to apply them for each individually. Other than that your mapping is correct and shouldn't be the issue. Edit: To conclude the discussion in the comments ...


2

Given your are using a VPS this is no suprise (guessing you only have a single core with 1-3GHz) and you won't be able to crunch the conversion down to a few minutes. You can try using -c:v libx264 -presets ultrafast but I'd guess it will still take you about 45-60 minutes to encode. Also remove the -crf option when using a preset. Be advised that the ...


2

Seeing that in the text of your question you have started discussing other utilities, i will assume that you are not interested in sticking with ffmpeg, but rather in getting the job done. In my experience with libav and MTS i have had no problems with the framerate, the files get remuxed perfectly. I have just attempted the following with one of my files: ...


1

I found this thread. There you can see that Avisynth has a plugin (GetDups) which will allow you to do exactly what you want.


1

There isn't really an alternative to x264vfw. Are you sure the error is with the codec and not your application? It's in wide use, such a major bug would definitely be found. Also be aware that h264 doesn't work in a frame by frame basis unless you encode only intra frames. VP80 is NOT h264, just a similar codec. If you need to develop an app you probably ...


1

You might want to try to enforce the original frame rate by using -r 29.97. FFmpeg is probably trying to adjust the framerate for some reason. Your syntax is otherwise correct and shouldn't produce that error. Regarding your third question. Simply not possible. You can omit frames when using codecs that encode frames individually but thats not the case with ...


1

RAM is not the critical part of a transcode, CPU is. Since it is working stream to stream, fairly minimal memory actually has to be required if the encoder is operating efficiently. The memory speed does matter for scratch space for the processor, but not so much the quantity. The CPU (or GPU if using GPU optimized encoding) is what does all the work and ...


1

You can do a simple image overlay using the following syntax: ffmpeg -i input.mp4 -i image.png -filter_complex "[0:v][1:v] overlay=25:25:enable='between(t,0,20)'" output.mp4 overlay=25:25 means we want to position the image 25px to the left and 25px down, originating from the top left corner. enable='between(t,0,20)' means we want the image to show ...


1

I struggled with a similar issue on Ubuntu 12.04.3 LTS. I fixed the problem using the static ffmpeg build which is available from http://ffmpeg.gusari.org/static/64bit/ffmpeg.static.64bit.latest.tar.gz



Only top voted, non community-wiki answers of a minimum length are eligible