Take the 2-minute tour ×
Video Production Stack Exchange is a question and answer site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation. It's 100% free, no registration required.

I made a simple animation in SketchUp and am trying to bring it into After Effects. When I do the AVI is all black in Footage and Composition.

Reading around it sounds like the most common issue is Codec but beyond that I'm a bit clueless here. When I open it in Adobe Media Encoder it shows H.264 Match Source - High bitrate which from what little I understand the H.264 should be acceptable?

Is there something else I should be looking for? How can I get the animation from SketchUp into After Effects?

EDIT WITH CLIP PROPERTIES:

In Adobe Premier Pro the clip's properties show:

  • Type: AVI Movie
  • File Size: 508.9 MB
  • Image Size: 1280 x 720
  • Frame Rate: 24.00
  • Total Duration: 00:00:08:01
  • Pixel Aspect Ratio: 1.0

AVI File details: Contains 1 video track(s) and 0 audio track(s).

Video track 1:

  • Size is 508.88M bytes (average frame = 2.63M bytes)
  • There are 193 keyframes.
  • Frame rate is 24.000 fps
  • Frame size is 1280 x 4294966576
  • Depth is 24 bits. Compressor: none.

Additional information: Lavf54.34.100

share|improve this question
    
The H.264 Match Source is the preset for output that you have selected, not the type of the input. (The match source means that the output will match the resolution and frame rate of the source video.) You need to actually get the media info from the properties of the clip in After Effects. It is probably a missing codec. –  AJ Henderson Dec 27 '13 at 16:06
    
Where would I find this? Right clicking the AVI found Interpret Footage but dont see anything about Codecs in here so thinking its the wrong place. –  Ryan Dec 27 '13 at 16:11
1  
I don't have my Adobe collection in front of me at the moment. I think that it it right click and then properties. It might be in Premiere Pro that it provides the details though. I work between the two so much that I sometimes forget which one has which feature when I'm not sitting at my editing rig. –  AJ Henderson Dec 27 '13 at 16:13
    
It was Premier that had the properties. Just updated question –  Ryan Dec 27 '13 at 16:38

2 Answers 2

up vote 1 down vote accepted

Not sure on the AVI but kept searching and found http://sketchucation.com/forums/viewtopic.php?f=11&t=18827

What OS are you using?

Vista 64 bit has codec issues, so if it is indeed a Vista 64 bit you need to export as a series of images (which is best anyway) and compile it in after effects.

I'm on Windows 7 so don't know why it was an issue to begin with but did the Export as Images instead. Then did a simple Import (Ctrl+I) which detected the jpeg sequence and that worked perfectly. Smaller file size then the AVI SketchUp exported too.

share|improve this answer
1  
The image sequence should work. This is actually a more standard way to work with animations (though generally a format supporting alpha channel is used so that transparency can be brought over). I generally use TGA sequences for anything computer generated. There are also video formats that support alpha, but it's easier to re-render frames and replace them when using an image sequence. The downside is generally size since there is minimal compression on an image sequence, but the quality is hard to match. Not sure if SketchUp supports alpha export though. –  AJ Henderson Dec 27 '13 at 16:09
    
I actually modeled a quick half circle behind my object, extruded it up, and gave it a lime green color. Then Keylight worked perfectly for what I needed off the image sequence. –  Ryan Dec 27 '13 at 16:17
    
If it is really that basic, you can do 3D shape extrusion natively in After Effects itself and then any of the 3D filters or camera tracking will work as well. –  AJ Henderson Dec 27 '13 at 16:19
    
Good to know but I had already modeled it to put in the SketchUp warehouse. Would these be beyond the AE capabilities? sketchup.google.com/3dwarehouse/… –  Ryan Dec 27 '13 at 16:20
    
Yeah, probably, the built in functionality is very, very basic. I haven't played with it all that much though because I generally use SoftImage for my 3D needs and export depth maps. –  AJ Henderson Dec 27 '13 at 16:26

First thing you should check is to make sure you don't have any 3rd party codec packs installed (like k-lite or etc), as they can cause a lot of problems when Adobe apps try to encode/decode movies.

Do you know what codec you're using. Avi is a container, not a codec, so you can put different file types inside of an Avi file.

Unless you're married to using avi, follow these instructions.

1) open your project

2) go to export -> animation

3) if you're on Windows click the box next to "Codec"

4) Then you'll want to look through the dropdown for "Compressor" and find something that Adobe supports

If you want list the codec choices you have, and I'll let you know which to use.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.