Take the 2-minute tour ×
Video Production Stack Exchange is a question and answer site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation. It's 100% free, no registration required.

I'm a complete beginner to After Effects and Premier Pro. When I typed directly into After Effects and then did a "Best Settings" render my text looks a bit pixelated. Is this the best quality AE can do or would it be better to import the text in another format for high quality? Transparent TIF for example? Is there another thing I should look at in the render settings to ensure the type renders crisp?

share|improve this question
add comment

2 Answers

The quality of the text is going to depend on the quality of the font. There are two types of fonts, bitmap and vector.

Bitmap fonts basically have pictures of each letter and information about how they should be spaced, each font size that is officially supported has its own picture. Vector fonts are a mathematical description of the characters and can be resized smoothly.

If you are using a bitmap font and not using a sufficient font point size, then you will get a pixelated image. Try using other fonts and/or adjusting the point size to find one that isn't pixelated. It should be perfectly possible to render fonts smoothly in After Effects directly.

share|improve this answer
    
I'm not using bitmap fonts. I only use TrueType or OpenType. In this case the font used was Arial. –  Ryan Dec 26 '13 at 21:21
    
@Ryan - Are you using a higher point size or using the % size adjustment to make it bigger? The font is rasterized on the layer based on your point size and then scaled based on the layer size. If you are adjusting the layer size with a small font point size, you would still get pixelization. –  AJ Henderson Dec 26 '13 at 21:31
    
I used Font Size only. –  Ryan Dec 26 '13 at 21:34
    
@Ryan - are you able to reproduce the problem in a project file you could share? I'll mess around a bit tonight and see if I can figure out how to reproduce your problem and fix it. I know I've done smooth fonts in AE natively, but I forget exactly what was involved. I don't remember anything special, but maybe I'm forgetting something. –  AJ Henderson Dec 26 '13 at 21:44
    
About to leave the office today but I can reproduce it in the morning –  Ryan Dec 26 '13 at 21:55
add comment

I suspect you have the view window set at less than 100% scale. Your quality setting should match your view screen scale. For example, if your view screen is at 50% you should set the quality to half. If the screen is at 49% or 51% the text will look jagged (aliased). The Auto setting on the quality drop down is useful to keep the closest quality setting to your scale.

share|improve this answer
    
this is happening not just in AE but when I render to an .mp4 –  Ryan Feb 5 at 14:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.