Take the 2-minute tour ×
Video Production Stack Exchange is a question and answer site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation. It's 100% free, no registration required.

I'm trying to add a light to a scene that has black text on a white background. My goal is to keep the light in position and slide in the text. As the text slides, part of the text will be less black because of the light.

I've added a light and positioned it correctly. I've also made sure my text is 3D-enabled and has "accepts lights" on.

The problem I'm having is that no matter how I position the light or tweak the material options, I can't figure out what to do so that the surface of the text changes intensity with the light that's being cast. The text will cast shadows (when turned on), but the surface won't change.

What do I need to do to get the surface of the text to change color (to grey or white) based on the light source?


Here's what it looks like:

enter image description here

enter image description here

share|improve this question
    
I don't know this one off the top of my head, but if I remember I'll take a look tonight when I get home. I think there is a setting about how the light interacts, but I've worked with so many different programs they sometimes cross in my head. –  AJ Henderson Jun 14 '13 at 17:35
add comment

3 Answers

Adjust Metal to 0% and Specular Shininess to taste in the material options of the text layer.

share|improve this answer
add comment

Play with the cone feather settings on the light. This will alter how harsh the gradient between lit and unlit sections of the text is.

Also, make sure your text is not totally black (#000000) otherwise the lighting will probably not look right.

share|improve this answer
add comment

I'm currently following this tutorial

and at 12:44 i think i got the same problem as you did in this situation. When I turned on "Accept lights" my text turned white to my frustration.

To fix it I tried experimenting with "Light transmission". I think this was set to 100% without me knowing, so when i adjusted it, my problem got resolved.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.