Video Production Stack Exchange is a question and answer site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am new to 3D software and have just started with Cinema 4d. This is a very noobish question but when I create any object in a project it always shows up pitch black.

The tutorial videos I have seen create objects where the faces can be see in a shaded grey. What am I doing wrong?

Image relating to the problem:

Thanks, Hiren

share|improve this question
This normally happens when you have a light in the scene and the light is inside the box such that it can impossibly light the box. But in your screenshot I don't see any lights in your scene, so that's not the case. – Saaru Lindestøkke Feb 17 '13 at 14:03
If you click on the object, in the lower right corner basic properties of the cube (like the Name, the Layer, Visible in Editor, etc...) will show up. Can you check if Use Color is set to Off? If it's set to something else it might be the cause of your colour problem. – Saaru Lindestøkke Feb 17 '13 at 14:06
Hi Bart thanks for the response! I have checked the object in question and the Color is set to Off. – Hiren Umradia Feb 17 '13 at 18:13
up vote 2 down vote accepted

This can either be an issue with OpenGL and you may want to disable it in the program settings (under "File) to test if thats the issue. Or you may have disabled the standard infinite light that is present in every new scene until you add your first light. Add an infinite light from the lights menu and see if that gives your objects some shading. Also try what @Bart Arondson said and look if you have the "Use Color" option enabled and set to black. If yes set it to "off".

share|improve this answer
Hello Paul, thanks for the response! I applied a light and it did show me the faces of the cube. However, what's strange is that when I turned Open GL off like you said, it showed me the cube's faces without the lights. I think its could be a problem with using my integrated graphics on my i7 CPU. Thank you for the help :) – Hiren Umradia Feb 17 '13 at 18:17
If you go to Preferences -> OpenGL -> Show OpenGL Capabilities... you can see if your graphics card meets Cinema4D's OpenGL requirements. – Saaru Lindestøkke Feb 17 '13 at 18:44
OpenGL is important for C4D to show advanced shading. The viewport is very limited in software mode. Always have OpenGL enabled as long as its not causing any problems (which is rather rare anyways). If adding a light shows you a shaded face then the missing infinite light was you problem. – Professor Sparkles Feb 17 '13 at 18:49
Hey bart, I just checked the capabilities and the computer seems fine to run it. I have added an infinite light and it seems to work with Open GL on. Thanks for your help guys :) – Hiren Umradia Feb 17 '13 at 19:23
in my case when i start the application there is no problem. but when i add light ...and after that i delete that light then the box turns to black.i solved that by unchaking the openGL in preference..but it creates some new problem with materials..adding some extra lines over the applied material.i have updated my graphics card..! – user3996 Apr 28 '13 at 15:51

I had the same issue but I fixed it. All I did was add light layers around my object & it no longer was black.

share|improve this answer

protected by JoshP Jan 22 '14 at 4:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.