Take the 2-minute tour ×
Video Production Stack Exchange is a question and answer site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation. It's 100% free, no registration required.

I've been trying to encode a video trailer for mobile Safari playback (iPhone). Using Handbrake for Windows, I selected the source .mov file and chose the iPhone 4 preset. I then checked off the Web optimized option and started the process.

The resulting video did not play on my iPhone's Safari browser, however.

http://mobilevideo.jt.citeeze.com/static/trailer.mp4

For reference, here is the original file:

http://mobilevideo.jt.citeeze.com/static/53159_high.mov

Thanks!

share
    
A similar question has been asked on stackoverflow: stackoverflow.com/questions/5722505/… And for a complete guide there is the Safari Developer Library –  Bart Arondson Jan 22 '13 at 22:42
    
Bart, I saw that answer but it was not specific to the tool I'm using. I've tried the baseline settings but they didn't work for me. –  Dimitry Jan 23 '13 at 14:32
    
Have you clicked through on the link in the first answer? Because there it says that you should end up with an .mp4 file. You have an .m4v file in the link. –  Bart Arondson Jan 23 '13 at 21:22
    
File updated based on first answer. –  Dimitry Jan 23 '13 at 22:38

1 Answer 1

up vote 2 down vote accepted
+100

Based on the link given in this answer on stackoverflow I will try to explain how to encode a video in an iPhone friendly format.

The steps below are carried out on a Mac, but the windows version of Handbrake should be similar.

  1. Open Handbrake.
  2. Go to File -> Open Source and browse to your video.
  3. Choose MP4 File as container.
  4. Input the settings shown below for the respective tabs:

Picture tab:

Keep aspect ratio - check
Width - 480 (set to 960 if encoding for the iPhone 4)
Anamorphic - None
Cropping - Automatic

Video tab:

Codec - H.264
Video quality - RF = 21
Constant framerate - 30

Audio tab:

Codec - AAC
Bitrate - 128
Sample rate - 44.1

Advanced tab:

Add the following text in the textbox labeled Current x264 Advanced Options String: if you're encoding for a pre iPhone 4 device:

cabac=0:ref=2:me=umh:bframes=0:weightp=0:subq=6:trellis=0:8x8dct=0:level=3

If it's an iPhone 4 or higher the text should be:

level=4.1

The Advanced tab should look like this (for the iPhone 3 encode): enter image description here

Here's a MediaFire link to the converted video for iPhones before the 4:

http://www.mediafire.com/?tlyzcg1hyygq8zf

share
    
Hey Bart, thanks for the thorough explanation. The encoding was great for everything but the latest iPhone (iOS6). Not sure what the problem could be. –  Dimitry Jan 23 '13 at 22:37
    
Could there be something in this doc? developer.apple.com/library/safari/#documentation/… –  Dimitry Jan 23 '13 at 22:37
    
For the iPhone 4 and up try to change the Advanced Options String to only level=4.1 and the width to 960 (but keep aspect ratio checked). And please try to work out some stuff yourself. I'm glad to help, but you've shown little effort in working out the problem even though I have pointed you to different resources. –  Bart Arondson Jan 23 '13 at 22:47
    
Thanks Bart. I've been trying this for three days now. I'm a software developer, not an encoding specialist, and your help is very appreciated. –  Dimitry Jan 24 '13 at 4:48
    
@Dimitry Did my solution for the iPhone 4 work as well? –  Bart Arondson Jan 24 '13 at 14:46

This site is currently not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .