Take the 2-minute tour ×
Video Production Stack Exchange is a question and answer site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation. It's 100% free, no registration required.

If I add a simple UV sphere that emits white light, and in the compositor add a Fast Gaussian blur effect, then when viewing on a transparent background there is a noticeable black halo around the glow.

Any ideas what the correct way to do this is?

Update: It seems to have something to do with the horizon colour being picked up by the blur effect. How do you prevent that from happening? As a work around I can set the horizon colour to white, but I don't think that's the correct way to do it...

Here you can see with a red horizon colour, and changing the colour of the emitter to blue the effect is quite pronounced:

enter image description here

share|improve this question
    
this is a good question. Did you try selecting only the light and not applying the blur to the whole layer? –  Travis Dtfsu Crum Sep 14 '12 at 13:35
    
@TravisDtfsuCrum Could you please show me how to do that? I'm trying to figure out the ID Mask nodes but not having much luck. –  magritte Sep 14 '12 at 22:30
    
go to the layer, do select all (ctrl or apple + a) then what I do is use the arrow key to press it once to the right then back to the left to make sure its still in the same spot but selects everything on the layer. Before you do the arrow key thing, make sure you have the move tool selected and not any selection tool. Once its selected try applying the blur. Let me know if this helps! –  Travis Dtfsu Crum Sep 17 '12 at 12:55
add comment

1 Answer 1

To ensure you get 'pure' transparency, you'll have to ensure the transparent world is used, instead of your (coloured) sky.

When using Blender Internal, make sure you have in the Render settings, under Shading panel Alpha set to Transparent

Transparency setting in BI

When using Cycles renderer, make sure you have in the Render settings, under Film panel the Transparency box checked.

Transparency setting in Cycles

Without these settings your alpha will be pre-multiplied with the sky color, which will look like your example.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.