Take the 2-minute tour ×
Video Production Stack Exchange is a question and answer site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation. It's 100% free, no registration required.

I am trying edit out a two minute clip from a long movie.

This is the command I'm using:

ffmpeg -ss 01:05:16 -t 120 -i input.avi -vcodec copy -an clips/output.avi

I thought that 120 would be in seconds, giving me a two minute clip. But the clip I get is over 45 minutes long. It seems to be as long as from the start time to the end of the film.

Why is this not working and what command should I use to get a two minute clip?

share|improve this question
    
ffmpeg is sensitive to the order in which you put the different options. Try changing that around (as Mulvya) suggests. –  Bart Arondson Dec 19 '12 at 23:13

2 Answers 2

Try putting-t 120 after -an

share|improve this answer
up vote 2 down vote accepted

I found that the time after -t has to be in the format 00:00:00. So, for a two minute clip, the command is:

ffmpeg -i input.avi -sameq -ss 01:05:16 -t 00:02:00 clips/output.avi
share|improve this answer
    
This is a perfectly fine solution, except you should (almost) never use -sameq - it doesn't mean 'same quality'. There are a few cases where it may be useful, but it is very much an advances option (so if you aren't sure that you need to use it, don't use it). –  evilsoup Jan 15 '13 at 19:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.