Take the 2-minute tour ×
Video Production Stack Exchange is a question and answer site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation. It's 100% free, no registration required.

I have a .MOV video -created with Final Cut Pro 7 - which I'm converting to .flv using FFMPEG. I'm very happy about the quality and the size of the output file, but whenever I have fade in/out transitions in the input video, I get a pixelate effect on the output file. Any advice on how to solve this, without increase too much the output file size?

FRAME_SIZE=720x576
BIT_RATE=1200k

ffmpeg -s $FRAME_SIZE -i $1 -g 250 -ar 44100 -deinterlace -b $BIT_RATE -minrate $BIT_RATE -maxrate $BIT_RATE -bufsize 10000k -qblur 0.3 $2

Where $1 and $2 are, respectively, the input and output file.

share|improve this question
    
Can you post what parameters you are using in ffmpeg? It sounds like a bitrate issue –  Colum Jul 21 '11 at 23:14
    
@Colum: There you go. –  Roberto Aloi Jul 22 '11 at 9:44
    
I think it is an issue with interlacing. Try removing that flag –  Colum Jul 23 '11 at 14:04
    
@Colum. That didn't help. Actually, it causes horizontal lines to be displayed on the output video. –  Roberto Aloi Jul 25 '11 at 12:29
add comment

3 Answers 3

Try converting the file using [MPEG Streamclip], MPEG Streamclip is a good free file converter. Export the project from Final Cut Pro 7 and use MPEG Streamclip to convert the file.

(http://www.squared5.com/)

share|improve this answer
add comment

You should explicitly specify a video codec using -vcodec as well as quality settings.

The problem is that ffmpeg's defaults aren't very sensible when you only specify a container format for the output, often choosing a sub-standard video format by default.

If you want H.264 output, try using the presets, e.g. -vcodec libx264 -vpre max. (To see what presets are available, try ls /usr/share/ffmpeg/*.ffpreset.)

share|improve this answer
add comment

Try the -sameq option. It tells ffmpeg to use the same quality in the output as in the input. I often find that ffmpeg likes to use sub-standard video codecs.

share|improve this answer
    
no it doesn't. It tells ffmpeg to use the same Quantizer. Common mistake. –  stib Dec 20 '12 at 6:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.