Take the 2-minute tour ×
Video Production Stack Exchange is a question and answer site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation. It's 100% free, no registration required.

In my case, I'm working with a file that does have audio, confirmed in the RAM preview and other checks mentioned above, however, I noticed after rendering, the first video file ha no audio (not even in the RAM preview any longer, the video layer is like my other imported video layers and still has the little audio icon with it). I had a audio fade-in on it but it worked before in the RAM preview and my audio fade-out on the last video still works fine. Some little option somewhere got toggled and yeah.... somewhere in there in those many great options AE provides...

The link to my .aep and project files on Google Drive:

and to my audio fade-out working, but no audio in the first half of the video:

  • https://youtu.be/pMf5JLBIPQk?t=1h35m22s

Thanks for any help. :)

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Make sure that audio is on in your output module. In versions prior to CC you had two choices: on and off, recently they've added an automatic function that turns on audio rendering if the comp has audio.

In the render queue you'll see this if you twirl down the output module triangle:

enter image description here

And you can set audio rendering in the output module window:

output module

Note that the output module is what determines whether audio gets rendered. It can be on when you do a RAM preview, but if it aint on in the output module, you aint gettin' it.

share|improve this answer
    
I don't see that option in my Adobe Media Encoder CC. See !pic –  Mikeumus Apr 16 at 2:26
    
My answer is for rendering from AE. That pic looks like you've got Media Encoder set up ok. Can you use something like ffprobe or mediainfo to check whether there is an audio stream present? The lack of audio could mean: • there's no audio stream, • there is an audio stream which is silent, or • there's something preventing you from playing the audio properly in the encoded file. –  stib Apr 16 at 3:44
    
I don't have enough reputation to select this as the answer yet but the Audio Output On was the trick. Pardon I didn't try it earlier. Thanks @stib –  Mikeumus Apr 24 at 15:30
    
@Mikeumus Nice it's solved now - you can't upvote at the moment, I could upvote for you ;), but please mark it as solved - below the reputation arrows, see the tour: video.stackexchange.com/tour. Thanks. –  poor May 9 at 16:23

Make sure the sound icon of the layer is enabled and check the audio waveform of the layer in your composition at this time.

enter image description here

For RAM Audio Preview see this answer: How can I preview with audio in After Effects and be able to pause / resume the preview?

share|improve this answer
    
My video layer did indeed have a waveform and the audio icon was checked "on". It was when I followed your RAM Preview answer using the "0" key to activate the playback that on about the 7th or so try, the audio finally faded in on the playback as excepted. Rendering now in the Media Encoder. Will report back once the file is rendered. Thanks. –  Mikeumus Apr 14 at 22:53
    
Turns out my render didn't have audio in the same style as my youtube link above. :( –  Mikeumus Apr 16 at 2:25
    
@Mikeumus If ram preview is fine, check your render settings. –  poor Apr 16 at 7:53
    
everything is setup to render the audio. I'm using the YouTube 720p present. –  Mikeumus Apr 17 at 21:09
    
@Mikeumus But you've also checked the keyframes right? –  poor Apr 21 at 9:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.