Take the 2-minute tour ×
Video Production Stack Exchange is a question and answer site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation. It's 100% free, no registration required.

I've got a 100x100px composition with a Mask containing a Stroke effect used to animate the drawing of a vector. The problem I'm having is when I drop this composition into a larger one and attempt to scale it up, the Brush Size in Stroke remains the same (e.g. the graphic is drawn with thin lines, instead of the thicker looking ones in the smaller comp).

I'm thinking some sort of expression magic might be the fix to this, but any input on how to maintain line thickness at any resolution/scale would be much appreciated. Thanks!

EDIT: I've attached a small demo project showing the issue I'm running into below: http://hellocld.com/stuff/stroke-issue.aep

share|improve this question
    
I can not reproduce that behavior. What version of After Effects are you using (always important to mention btw.)? –  Professor Sparkles Jun 4 at 16:46
    
I'm currently using CS5 –  Chris Langford Jun 4 at 16:48
    
Ok so the problem is that the stroke effect isn't scaling when you scale the imported composition? –  Professor Sparkles Jun 4 at 16:49
    
That's correct. As I scale the imported composition all the paths scale appropriately, but the "Brush Size" setting on the Stroke effect remains at it's initial setting, so the stroke it displays appears thinner. –  Chris Langford Jun 4 at 16:52
    
Could you upload a simple demo file that shows the issue? I kind of suspect that is might be a bug in CS5 as this doesn't seem to happen in CS6. –  Professor Sparkles Jun 4 at 17:14

1 Answer 1

up vote 1 down vote accepted

Easy fix, you see the small sun icon on the imported comp layer? Disable that, that basically means that the comp should act like the layers within it should act like they are in the parent comp. It negates the transformation your are applying to it and the effect will just keep its pixel value its supposed to have, you are not "blowing it up" like you would expect. If you disable it the imported comp will act like a rendered video.

If you have huge pixelation going on just go to full resolution in the preview and it will be fine, though the layer will not act like a vector, you will have a rasterized image so keep in mind to have a big enough resolution if you want to scale it up. Better to have it bigger and scale it down than having not enough.

enter image description here

share|improve this answer
    
That sounds like it'd work alright. Reason I'm using 100x100 is because I'm creating a library of animated icons. Since they're all vector though, creating them at much higher resolutions (something like 2000x2000) won't affect filesize/performance, will it? –  Chris Langford Jun 4 at 17:33
    
It won't effect the after effects project file size. If you render a video at that resolution it will certainly effect the file size of the video. Performance shouldn't drop all that much as long as you don't do all too fancy stuff with your vector graphics. If you just do some animations you wont see all that much diffrence. –  Professor Sparkles Jun 4 at 17:34
    
Right, right. I'm just concerned with the project file. Thanks! –  Chris Langford Jun 4 at 17:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.