Video Production Stack Exchange is a question and answer site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After installing Mavericks, Premiere has slowed to a crawl. It seems to have the most trouble with AE comps imported through Dynamic Link.
I believe this is related to the App Nap "feature", but disabling App Nap on all Adobe programs hasn't cleared it up. When a Dynamic Link clip need to be rendered, it will estimate 9 minutes or something ridiculous. The Energy tab in Activity monitor shows that App Nap is active on Aftereffects, even though it's supposed to be disabled. By clicking back and forth between Premiere and AE (not constantly), I can get the render time back to ~30sec like it should be.
Any thoughts? Is there a background process that needs to have App Nap disabled? Could it be something else entirely?

Mid 2011 iMac, 16 GB RAM, OSX Mavericks, Premiere Pro CC 7.2.2, Aftereffects CC

share|improve this question
I don't know the Mac version particularly well, but if the application is still app naping, it sounds like something is wrong with how app nap was turned off. – AJ Henderson Apr 30 '14 at 23:08
I have found that apple loves to run background processes on their machines. Go into activity monitor and see whats running. Chances are there are a bunch of things running you dont need. For one (I think its called sataliteLookup) there is the process that looks for software updates automatically. It will free up some CPU time for you. Chances are there are lots of little things like this that came with Mavericks that are running. – Dave Aug 1 '14 at 19:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.