Take the 2-minute tour ×
Video Production Stack Exchange is a question and answer site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation. It's 100% free, no registration required.

Video in source preview is lagging but it plays fine in video players. What may cause this? Why premiere is not using standard codecs for source preview?

Specs: Video is: h264 2704x1536 @29.97fps (GoPro footage) System is: Core i7 2.3, 8GB RAM, GeForce GT 650M (MacBook Pro, bootcamp) Adobe Premiere CS 6

share|improve this question
    
Possibly Related... video.stackexchange.com/questions/9976/… –  AJ Henderson Mar 11 at 19:45
    

2 Answers 2

up vote 1 down vote accepted

Premiere's preview isn't simply a viewer and can't make as much use of caching as it needs to be able to scrub quickly in any direction. Interframe compression also trips it up for the same reason. I believe it also processes the entire amount of data. The video size you are using is pretty large and bandwidth intensive, so unless you are working from very fast disks (solid state) (or a fast CPU if it is heavily compressed) and have fast RAM to deal with the rate of uncompressed data, it is easy for the playback to fall behind.

The related questions talk a bit more about methods of getting around this (such as letting Premiere finish generating conformed versions of the video or reducing the resolution of playback so that not all pixels have to be rendered).

share|improve this answer
    
Data rate is only 4MB/s. Also Windows Media Player plays it smoothly while Premiere preview is choppy even on 1/8 resolution –  Poma Mar 11 at 20:22
    
If your data rate is only 4MB/sec then you have to be using some seriously heavy compression. Your uncompressed video is around 124 MB a second (which is what that video has to decode to). Premiere will try to fully decode the stream which is going to be pretty CPU intensive for that much decoding. How is your CPU and/or GPU utilization during playback? I'm a bit surprised about the 1/8th still being a problem in that case, h.264 in general doesn't handle well in NLEs though, so conforming is still the best bet normally. –  AJ Henderson Mar 11 at 20:26
    
@Poma - It does seem like it is a performance issue, even without conforming, I was able to play back a GoPro 2.7k file on my rig in Premiere Pro with no issues. I've got a 2.93ghz fist gen i7 with 12GB of high speed triple channel ram and a Radeon 6970 graphics card. I tried playing it back in quicktime and it stuttered a bit, but playing it in Premiere was smoother. There still was a little bit of bounciness, but my impression was that that was the original footage. Even a 4k sample was ok. –  AJ Henderson Mar 11 at 22:37
    
looks like the cause of the problem was software rendering. In project settings I have only Mercury Playback Engine Software Only. Don't know how to fix it though. –  Poma Mar 11 at 23:01
    
@Poma - that's the only option I have as well, but it still runs fine. That is just because you don't have CUDA support, however you could try one of the CUDA hacks to get the 650M to be recognized for CUDA support. It may be that your 2.3ghz processor is too slow without CUDA support though. There is a nice write up on enabling CUDA on non-officially supported NVidia cards here –  AJ Henderson Mar 11 at 23:04

I had this as well one time. Solution for me was to edit in the correct video mode and fps. Maybe you can try to create a sequence from a standard HD DSLR preset? Or first try to edit in that preset. Prem 6.0 was created with native h.264 support, so you shouldn't need any proxies.

share|improve this answer
    
The problem was with source preview so it has nothing to do with the sequence. But I chose to match sequence format to source video anyway. –  Poma Mar 12 at 6:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.